Qlik Community

Qlik Brasil

Group community for Brazil users. discussion only in Portuguese.

Highlighted
pedromsouza
Contributor

Novos objetos não aparecem

Pessoal, estou com o seguinte problema: para criar novos objetos, conecto-me ao servidor onde o qlikview server está instalado via Windows RDP e faço as alterações no qlikview desktop instalado lá.

Antes de editar, faço uma cópia do qvw para pasta meus documentos ou área de trabalho, edito, testo e só então coloco de volta substituindo a versão anterior na pasta que o qlikview server "puxa".

O problema é que novos objetos estão sendo ignorados. Parece que o server fica abrindo uma versão antiga do qvw presa em algum tipo de cache e não mostra os objetos recém criados.

Algum sabe o que pode ser?

1 Solution

Accepted Solutions
pedromsouza
Contributor

Re: Novos objetos não aparecem

Descobri o problema.

Achei a solução neste tópico QVW not getting replaced in source document

Apaguei as pastas PRJ criadas pelo Document Analyzer e refiz as alterações que havia feito. Aí atualizei na versão do access point e já apareceram as modificações.

Obrigado pela disposição em ajudar!

9 Replies

Re: Novos objetos não aparecem

Pedro, sabe me dizer se em seu ambiente existe o Publisher?

Se sim, é porque o arquivo que fica publicado, esta em outro diretório

pedromsouza
Contributor

Re: Novos objetos não aparecem

Eu acredito que não, pois a parte de licença do publisher no QMC está limpa e nos serviços em execução não tem o QDS em execução.

Captura de Tela 2018-07-13 às 18.10.39.png

pedromsouza
Contributor

Re: Novos objetos não aparecem

Ah sim, esqueci de dizer. Se eu for agora e abrir o documento na pasta onde o server "puxa", aparece sem os objetos novos no qlikview desktop. Mas se eu copiar para qualquer outra pasta, como ïmagens"do windows, por exemplo, e abrir, os novos objetos aparecem.

Re: Novos objetos não aparecem

Bom, verifique se realmente esta colocando o painel no diretório de publicação de seu servidor.

Outras tentativas:

Tente limpar o cache do seu navegador e o do próprio qlik (embaixo da app, no access point, tem um "More Details", clica lá e depois em "Remove Last Document State").

Reinicie os serviços do qlik

Re: Novos objetos não aparecem

Estranho....

pedromsouza
Contributor

Re: Novos objetos não aparecem

Tentei as duas coisas e o problema persiste.

Se você puder disponibilizar algum contato pessoal whatsapp/email, envio um vídeo demonstrando o problema.

Re: Novos objetos não aparecem

pedromsouza
Contributor

Re: Novos objetos não aparecem

Descobri o problema.

Achei a solução neste tópico QVW not getting replaced in source document

Apaguei as pastas PRJ criadas pelo Document Analyzer e refiz as alterações que havia feito. Aí atualizei na versão do access point e já apareceram as modificações.

Obrigado pela disposição em ajudar!

Re: Novos objetos não aparecem

Boa, nem havia passado pela minha cabeça a questão do prj