Qlik Community

Qlik Brasil

Group community for Brazil users. discussion only in Portuguese.

Highlighted
pauloandre
Contributor II

Objeto tipo imagem não aparece no Access Point

Prezados,

Criei um objeto tipo tabela simples com representação da expressão tipo imagem. Na Utilização pelo Personal funciona tudo OK, porém quando visualizo no Access Point ou pelo WebView a imagem não é apresentada, como mostra as imagens abaixo.

Alguem saberia o motivo??

Estou utilizando o QV 12.10

Em anexo o qvw para analise

imagem-comfoto.JPG

imagem-semfoto.JPG

Tags (1)
1 Solution

Accepted Solutions
MCampestrini
Valued Contributor

Re: Objeto tipo imagem não aparece no Access Point

Paulo

Basta você chamar a função com o nome da pasta onde estão as imagens

Call Qvc.Icons(<pasta das imagens>, <nome dos arquivos>);

No caso do nome dos arquivos, se você colocar * vai carregar tudo.

Márcio Rodrigo Campestrini
16 Replies
Employee
Employee

Re: Objeto tipo imagem não aparece no Access Point

Aqui não apareceu de jeito algum

Capturar.PNG

pauloandre
Contributor II

Re: Objeto tipo imagem não aparece no Access Point

Clever,

está usando o webview ou não??

MCampestrini
Valued Contributor

Re: Objeto tipo imagem não aparece no Access Point

Aqui apareceu nos modos normal e webview.

Estou utilizando a versão 12.0.

Tive um problema semelhante, mas com imagens via HTTP.

Postei o problema no espaço Qlikbug (aqui na comunidade) e recebi a resposta do meu problema.

Márcio Rodrigo Campestrini
Employee
Employee

Re: Objeto tipo imagem não aparece no Access Point

Não, modo normal

pauloandre
Contributor II

Re: Objeto tipo imagem não aparece no Access Point

Márcio,

qual foi a solução??

pauloandre
Contributor II

Re: Objeto tipo imagem não aparece no Access Point

Estranho esse comportamento, em alguns funciona normalmente, em outros somente de uma forma e em outro não funciona. teria alguma ideia do motivo?

MCampestrini
Valued Contributor

Re: Objeto tipo imagem não aparece no Access Point

No meu caso (como era HTTP/HTTPS) era um parâmetro do Qlikview.

Tente abrir o aplicativo na versão 12.0 para ver se funciona, se sim, avalie se você precisa realmente da versão 12.1.

Márcio Rodrigo Campestrini
pauloandre
Contributor II

Re: Objeto tipo imagem não aparece no Access Point

Fiz update do ambiente (servidor e personal) da 11.20 para 12.10, não tem como voltar para a 12.0

MVP
MVP

Re: Objeto tipo imagem não aparece no Access Point

Na realidade mudança de funcionamento.

Podemos "voltar" ao padrão do 11.2

Da forma como mostro na gif animada, da para mudar pela interface

Mostrar Imagem.gif

ou


C:\Users\SEU_USUARIO\AppData\Roaming\QlikTech\QlikView

edite o settings.ini

e na linha aonde tem (se nao tiver acrescente) mude de 0 para 2


AllowGeneralAccessToImagesThroughURL=2

as possibilidades são

0 = No access at all

1 = Access through "http://" //
2 = Full access (same behavior as in 11.20)