Qlik Community

Qlik Brasil

Group community for Brazil users. discussion only in Portuguese.

Highlighted
Not applicable

Perda dos usuários na reinicialização do Servidor

Pessoal, tenho um caso que quando reiniciamos o servidor, as licenças Named Cal e Document Cal são removidas, sendo necessário acessar o QMC e readicionar todos usuários novamente.

Trata-se da última versão do QV Server 11R2, não me recordo agora da build.

Alguém sabe o que pode ser?

Tags (1)
1 Solution

Accepted Solutions
Not applicable

Re: Perda dos usuários na reinicialização do Servidor

Pessoal, só resolvemos este problema colocando a versão 10R6.

3 Replies
Not applicable

Re: Perda dos usuários na reinicialização do Servidor

Ja encontrei este mesmo problema na versão 11 SR1.

Sempre que o serviço "Qlikview Server" é reiniciado ele perde a configuração das contas de Named cal.

Agora com relação aos licenças atribuídas por Document Cal se não me engano fica gravado no arquivo "CalData.pgo" (na raiz do diretório apontado no QMC: System / Setup / Qlikview Servers / Folders / Root Folder).

Nunca chegou a dar problemas com as documents cal's quando o servidor ou serviço eram reiniciados.

Abraços

caique_zaniolo
Not applicable

Re: Perda dos usuários na reinicialização do Servidor

Exatamente Eduardo. Os arquivos .pgo são arquivos de configurações e licenciamento interno do QlikView Server.

A perda normalmente acontece quando estes arquivos estão armazenados em um disco de rede (storage). Mesmo o disco aparecendo como C: D: , etc, ele pode ser um disco de rede de um SAN ou NAS.

Uma forma de evitar problemas com estes arquivos é configurar uma pasta separada para eles (como Root Folder em QVS > Folders). Nesta pasta não deve ter nada além dos arquivos de configuração.

Seus QVW devem ficar em uma pasta separada e configurados como Mounted Folders.

Document CALs não são tão afetadas porque são armazenadas em arquivos diferentes (.meta na mesma pasta do QVW).

Abraços

Not applicable

Re: Perda dos usuários na reinicialização do Servidor

Pessoal, só resolvemos este problema colocando a versão 10R6.