Qlik Community

Qlik Brasil

Group community for Brazil users. discussion only in Portuguese.

Highlighted
MCampestrini
Valued Contributor

Problemas com a informação de licenças em uso

Bom dia


Estou com um problema. Tenho um script que lê o arquivo CalData.pgo.xml para exibir a quantidade de licenças que estão sendo utilizadas. Hoje percebi que esse arquivo (bem como o arquivo CalData.pgo) não tem atualização desde o dia 31/10/2015. Alguém tem ideia do que pode ter acontecido?


Obrigado!


Márcio

Márcio Rodrigo Campestrini
1 Solution

Accepted Solutions
pablolabbe
Valued Contributor II

Re: Problemas com a informação de licenças em uso

Ele funciona somente conectado a API do QMC.

Se você instalar o conector  no servidor do Qlikview, você consegue automatizar a carga automática.

Ele tem alguns requisitos de instalação e configuração de acesso. Pode ser que isso não tenha ficado definido corretamente no teu ambiente

4 Replies
pablolabbe
Valued Contributor II

Re: Problemas com a informação de licenças em uso

Márcio,

Se o ambiente foi atualizado de lá pra cá, as configurações do Qlikview podem ter sido sobrescritas e assim ter desativado a geração destes xml.

A Qlik não recomenda o uso deste recurso em produção. Eles usam isso para debug em caso de problema, por isso sugiro utilizar o documento + conector descrito aqui: Qlikview Server CAL Managerc

Funciona que é uma beleza.

Abraço,

Pablo

MCampestrini
Valued Contributor

Re: Problemas com a informação de licenças em uso

Bom dia Pablo

Eu já tinha conhecimento dessa solução, mas não estava utilizando pois ela não estava carregando via QMC. Essa opção deveria funcionar ou o aplicativo somente irá funcionar em standalone?

Márcio

Márcio Rodrigo Campestrini
pablolabbe
Valued Contributor II

Re: Problemas com a informação de licenças em uso

Ele funciona somente conectado a API do QMC.

Se você instalar o conector  no servidor do Qlikview, você consegue automatizar a carga automática.

Ele tem alguns requisitos de instalação e configuração de acesso. Pode ser que isso não tenha ficado definido corretamente no teu ambiente

MCampestrini
Valued Contributor

Re: Problemas com a informação de licenças em uso

Pablo,

Localmente o aplicativo está funcionando. O meu problema é somente a carga via QMC. Já segui os passos para inclusão do usuário administrador no grupo "QlikView Management API', mas ainda assim não funciona.

Sem título.png

Márcio Rodrigo Campestrini