Qlik Community

Qlik Catalog

Discussion Board for collaboration on Qlik Catalog

cancel
Showing results for 
Search instead for 
Did you mean: 
haskia
Partner
Partner

Integrating QDC Catalog in Qlik Sense via QDC Catalog Service API

Hello, 

After having successfully established the feature "Publish to Qlik Sense", I found this Instruction  on integrating Qlik Data Catalyst with Qlik Sense Enterprise.

However, I am stuck at the following points:

==============================

2. Enable the QDC Catalog Service:

Open the services.conf file located here: C:\Program Files\Qlik\Sense\ServiceDispatcher.
In the qdc-catalog-service section, set Disabled=false.

=============================

In our services.conf file there is no such field. See below extract:

==============================

[qdc-catalog-service]
Identity=Qlik.qdc-catalog-service
DisplayName=QDC Catalog Service
ExePath=dotnet\dotnet.exe
UseScript=true

[qdc-catalog-service.parameters]
..\QdcCatalogService\qdc-catalog-service.dl

==============================

I followed through the remaining points according to the instruction in above link and instructions in the Qlik Data Catalyst December SR1 Integration Guide (Feb 18, 2020).

But when I reached point no. 8 explaining the "QDC Catalog Service Configuration" I could not get any valid results. 

  • In the first tab [PostgreSQL Server] I am not sure which database inforamtion to add. Does it refer to the QS or the QDC database? Which user and database would this be i a default installation? What does the error message "Failed to test provided PG Server information: A task was canceled." mean.
  • In the second tab [QDC server] I can test the connection sucessfully but when I click Apply it throws an error: 
    "Failed to save QDC Server information: Object reference not set to an instance of an object." 
  • In the third tab [QDC JWT], it seems like a new JWT is created. Do I need to paste the previously built JWT token here?

 

System Specs: CentOS 7.7 | Java 1.8.0 OpenJDK | QlikSenseServer 13.62.7 (Feb 2020 Patch 1) | Qlik Data Catalyst 4.4.2 15.370 Dec. 2019 SR2 |

Thank you for your help! 

 

Labels (1)
1 Solution

Accepted Solutions
DmitryDmitriev
Employee
Employee

Hi Roman,

Thank you for reaching out. I´ve tried contacting you through the support case you have raised regarding this issue.


Please try to restart both Tomcat and Qlik Sense services and try saving the configuration again.

If that fails,  please reply on the support case with a suitable timeslot in order to troubleshoot this together during a working session.


As a last resort, you may add the following line as mentioned by the user Haskia.

 

2. Enable the QDC Catalog Service:

Open the services.conf file located here: C:\Program Files\Qlik\Sense\ServiceDispatcher.
In the qdc-catalog-service section, set Disabled=false.

=============================

[qdc-catalog-service]
Identity=Qlik.qdc-catalog-service
DisplayName=QDC Catalog Service
ExePath=dotnet\dotnet.exe
UseScript=true
Disabled=false     <<<  Add this line and save the file. Restart Qlik Sense Services and try again.

 

 

We hope the above was helpful and remain at your disposal for any other queries you might have.


Thank you for your time.

View solution in original post

18 Replies
ThiebaudS
Partner
Partner

Hi there,

1. Just add the "Disabled=false" instruction in the [qdc-catalog-service] section if not present. 

2.  The PostgreSQL Server access details on the /api/qdc/v1/setup/ui/page.html page refer to the QS database. So you will probably have something like : server=localhost, port=4432, user=qliksenserepository, Database=SenseServices

3. The error you have on the QDC server page is pretty strange. I'm sorry I've never experienced this one... Are you specifying a local QDC or Active Directory account ? In my case, I use the local QDC podium account.

4. If the publish to Qlik Sense feature is already set up, you can ignore this part since you already have the qdc virtual proxy, the jwt, the qlik-data-catalyst user, and so on.

Hope this helps.

Best regards,

Thiebaud

haskia
Partner
Partner
Author

Thank you for your quick response.  Luckily I got it working by now. 

If have added the line in the file as you recommended. 

The error on the [PostgreSQL Server] tab occured due to a wrong password. 😅 Only after successfully registering the first step, I was able to save the data on the [QDC server]. 

For everyone else stuck at this point. I only got it working after establishing trust between the SSL-certificates used on each server and making sure the mounted windows drive is mapped to the correct UID/GID of the "qvd" user.

--- 

One suggestion for the Qlik Team. You could increase visibility of this instruction page.. It is extremely helpful and I only found it through the forums after quite some searching. Maybe you could add a reference in the Qlik Data Catalyst Integration Guide, which is  available at the downloads page? 

ThiebaudS
Partner
Partner

Hi Haskia,

Good to know that you've fixed it ! 🙂

To be honest I had this feature working, but it doesn't work anymore since I've done some upgrades of QS and QDC and I don't know why...

In Qlik Sense QVD Catalog, I can see the QDC tags and sources in the drop down list, but no QVDs are displayed. (see screenshot). So I guess the communication between QS and QDC is OK, but I don't understand why I have no QVDs displayed...

What do you mean by "establishing trust between the SSL-certificates used on each server and making sure the mounted windows drive is mapped to the correct UID/GID of the "qvd" user" ? What have you done exactly ?

Maybe it can help me fix my issue.

Thank you very much.

Thiebaud

haskia
Partner
Partner
Author

I understand your troubles. I have the same problem now that I have rebooted the QDC server. 

Here are some things, I am currently checking:

  • Does the "Publish to Qlik"-feature  still work? Can you reload without problems?
  • Does the "QDC Import" feature  still work? Schedule a Reload. Do you see something under "Total QVDs found" in QVD Import Logs. 
  • Is the postgres connection in Qlik Sense still working? I had to open firewall ports in firewall-cmd for postgres service. (<< make sure they are not open to the Internet). 
  • On the QDC machine - when logged in as qdc user (tomcat user) - can you access the folder "/qvd-share" which connects to the mounted QS drive? If not you can try to edit the uid/gid settings in your etc/fstab accordingly. See my screenshot.
  • When connected to the Qlik Sense Server machine via RDP - can you access the URL of QDC without problems?

Regarding the trust. Since we have implemented CA-signed SSL certificates everywhere, I have added the QDC's certificate in the Qlik Sense Certificate Manager under Local Machine > Trusted Authorities, Trusted Devices & Trusted Publishers.

However,  neither this nor any of the steps above did the trick for me. I am stuck with the same situation as your screenshot now. That's really frustrating as everything was working perfectly fine a few hours ago. 

ThiebaudS
Partner
Partner

I'm sorry for you, but also happy that I'm not the only one encountering this issue. Sorry 😄

Yes, I've also checked all the steps you've described, but still haven't figured it out.

The publish to qlik sense feature is working well, the QDC import feature too,  the share folder between QDC and QS is OK, and all connections between the 2 servers are working...

I will let you know if I found anything.

ThiebaudS
Partner
Partner

Hi @haskia 

Have you been able to fix this issue on your end ?

I've just upgraded to QDC April 2020 release, and I still have the same problem...

Best regards

Thiebaud

haskia
Partner
Partner
Author

Hi Thiebaud,

Same here.. I installed the April 2020 upgrade for QDC today , but the problem remains the same. I think it is a problem with the QS Server. Are you using any other services that integrate the Qlik Sense API's  like NPrinting, Insights Bot? Are they working properly? 

One very last possibility could be a mismatched entry for our central node host name in Qlik Sense. It was selected automatically from the Azure VM during the installation process when QS was installed. The URL does not work properly and does not match our SSL-certificate Wildcard URL. In a few weeks we will try to change the server host name when the update to Qlik Sense April 2020 is scheduled -- but this is honestly the very last possibility I can think of.

Best regards

 

René

Christopher_Ortega

I regret that you are still having an issue.  Can I ask you to please open a support ticket at https://support.qlik.com/

In that manner we can get someone to work with you directly to resolve your issues.

Thanks!

ThiebaudS
Partner
Partner

@haskia I don't think the issue is on QS part, but more on QDC. To answer your question, I have several other services using the QS APIs (multi-cloud setup with qlik sense on kubernetes for example) and everything works fine.

 

From what I understand, when you navigate to the QDC Catalog on QS, there are at least 2 API calls to retrieve the data from QDC:

- The first one is https://<qliksenseURL>/<virtual_proxy>/api/qdc/v1/qdc/entity/getAllTags and will retrieve all tags from QDC. This one is working.

- The second call is https://<qliksenseURL>/<virtual_proxy>/api/qdc/v1/qdc/catalog/v1/pagedQVD and should retrieve all QVDs, but it returns nothing. 

If you debug it further, you will see that it seems to call QDC with https://<datacatalystURL>/qdc/catalog/v1/pagedQVD but  returns a HTTP error 400.

Then if you check the catalina logs in QDC, I have: 

No mapping found for HTTP request with URI [/qdc/catalog/v1] in DispatcherServlet with name 'dispatcher' [PageNotFound[http-bio-8080-exec-144]]

No handler found for GET /qdc/catalog/v1 [RestExceptionHandler[http-bio-8080-exec-144]]org.springframework.web.servlet.NoHandlerFoundException: No handler found for GET /qdc/catalog/v1

 

@Christopher_Ortega which category should be used when creating a support case for QDC ? There is no "Qlik Data Catalyst" section.

Moreover, is there any link to the qdc api documentation somewhere ? 

Thanks