Qlik Community

Qlik Compose for Data Warehouses

Discussion board for collaboration on Qlik Compose for Data Warehouses.

Announcements
Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
badgerriaan
Contributor III
Contributor III

SOLVED: Compose ETL How can I display more than 2 Mappings (Customisation)

Hi,

Bit of a technical one 🙂

I am trying to see if I can't customise Compose to show me more than the default 2 Mappings. This is very irretating.

So Far I have traced it to the Angular/View and you can see in screenshot 1 the live HTML from my compose.

I scratched around and found the source view (..Compose\webroot\views\datawarehouse\ETL) with the values inside and also found a JS file that references this HTML file. I tried to edit the file by changing the value to 3 from 2 for testing.

Compose\webroot\scripts\services\composeServices.js
src:"views/datawarehouse/ETL/ETL_mappings.html"


Compose\webroot\views\datawarehouse\ETL\ETL_mappings.html
<div ng-repeat="map in rowData.entity_mappings | limitTo:2" class="mapItemRow">
<div ng-if="rowData.entity_mappings.length > 2">

But nothing happened. Even after restarting the Compose Service.
Is there anyone else out there that have given this a go?

 

Labels (3)
2 Solutions

Accepted Solutions
Nanda_Ravindra
Support
Support

Hi there,

    You are on the right track to changing that value. Did the value change back to 2 after you restarted the service?

Please open a support case if you still looking into changing the default value from 2 to 3.

 

Thanks,

Nanda

 

View solution in original post

badgerriaan
Contributor III
Contributor III
Author

Hi, I tried it again today and for some reason, it worked as expected. Not sure what the issue was. Maybe a bug in the older version. I am running Compose August 2021 (2021.8.0.336) at the moment.

I just edited the HTML file, saved it and refreshed the web page. Restarting the service does nothing.

For the test today I changed the value from 2 to 5. Works like a charm and now I can see more mappings before you have to click the show more button.

Changed Lines in Compose\webroot\views\datawarehouse\ETL\ETL_mappings.html:
Line 50: <div ng-repeat="map in rowData.entity_mappings | limitTo:5" class="mapItemRow">
Line 66: <div ng-if="rowData.entity_mappings.length > 5">

The next Challenge is going to be to get the table rows to resize when you choose to toggle between Show All Mappings or Enabled only. To not have those big White empty boxes 🙂

badgerriaan_0-1648636700440.png

 

View solution in original post

4 Replies
Nanda_Ravindra
Support
Support

Hi there,

    You are on the right track to changing that value. Did the value change back to 2 after you restarted the service?

Please open a support case if you still looking into changing the default value from 2 to 3.

 

Thanks,

Nanda

 

badgerriaan
Contributor III
Contributor III
Author

Hi, I tried it again today and for some reason, it worked as expected. Not sure what the issue was. Maybe a bug in the older version. I am running Compose August 2021 (2021.8.0.336) at the moment.

I just edited the HTML file, saved it and refreshed the web page. Restarting the service does nothing.

For the test today I changed the value from 2 to 5. Works like a charm and now I can see more mappings before you have to click the show more button.

Changed Lines in Compose\webroot\views\datawarehouse\ETL\ETL_mappings.html:
Line 50: <div ng-repeat="map in rowData.entity_mappings | limitTo:5" class="mapItemRow">
Line 66: <div ng-if="rowData.entity_mappings.length > 5">

The next Challenge is going to be to get the table rows to resize when you choose to toggle between Show All Mappings or Enabled only. To not have those big White empty boxes 🙂

badgerriaan_0-1648636700440.png

 

Dana_Baldwin
Support
Support

Hi @badgerriaan, did @Nanda_Ravindra comment help to resolve the issue? If so, please mark it as solution accepted.

Thank you!

badgerriaan
Contributor III
Contributor III
Author

Hello, I have marked my post as the solution, as it contains the solution. My original post was actually already the solution. Qlik Compose might have had some issue in the previous version that I had installed that prevented it from working correctly. @Nanda_Ravindra  did just confirm I am on the right track but does not contain any actual solution to the problem.