Qlik Community

Qlik Connectors Discussions

Discussion Board for collaboration regarding Qlik Connectors.

Highlighted
baarathi
Contributor II

Access to path is denied. This can be changed using the FileSystemAccessAllowedPaths deploy config

Access to path D:\Capture.png is denied. This can be changed using the FileSystemAccessAllowedPaths setting in deploy.config

 

I am trying to attach a file to mail (smtp connector) using absolute path.  I am facing the above error. What is the neccessary change need to be done in deploy.config of web connectors to overcome this. Any suggestion would be welcomed

Baarathi

Thanks and Regards.

1 Solution

Accepted Solutions
MVP & Luminary
MVP & Luminary

Re: Access to path is denied. This can be changed using the FileSystemAccessAllowedPaths deploy conf

There are some examples in the deploy.conf file.

 <!-- 
  ******************************************************************************************************
  ********** This replaces the <AllowConnectorsFileSystemAccess> element in previous versions **********
  ******************************************************************************************************
  
  Some connectors can read/write to disk, this element lets you whitelist which paths the connectors are permitted to access.
    
  Notes:
  * Multiple paths should be delimitted with a semicolon (;).
  * If you want to white list ALL paths use a *
  * This setting applies across all connectors.
  * The account running the connector exe must also have permission to access any file in question.
  * Leaving it empty is equivalent to denying the connectors file system access.
  
  Some Examples:
  <FileSystemAccessAllowedPaths>c:\QWC\TempFiles;c:\SomeOtherDirectory</FileSystemAccessAllowedPaths>
  <FileSystemAccessAllowedPaths>c:\</FileSystemAccessAllowedPaths>
  <FileSystemAccessAllowedPaths>*</FileSystemAccessAllowedPaths>
  -->

Can you explain what you don't understand? All you need to do is copy one of the examples, add it below the comment section with the examples and change the path setting between the element tags.


talk is cheap, supply exceeds demand
5 Replies
MVP & Luminary
MVP & Luminary

Re: Access to path is denied. This can be changed using the FileSystemAccessAllowedPaths deploy conf

As the message says there's a FileSystemAccessAllowedPaths setting in the deploy.config file. You need to change that setting and include the path 😧 to it.

Personally I wouldn't do that. Instead I'd create a specific folder like D:\Images and put the Capture.png image in that folder. Then I'd add only D:\Images in the setting for FileSystemAccessAllowedPaths. Otherwise your entire 😧 disk will be accessable by the smtp connector. And someone might take advantage of that to mail files that shouldn't be mailed.


talk is cheap, supply exceeds demand
baarathi
Contributor II

Re: Access to path is denied. This can be changed using the FileSystemAccessAllowedPaths deploy conf

<AllowRemoteAccess>false</AllowRemoteAccess>
<AllowConnectorsFileSystemAccess>  <FileSystemAccessAllowedPaths>c:\QWC\TempFiles;c:\SomeOtherDirectory</FileSystemAccessAllowedPaths> <FileSystemAccessAllowedPaths>c:\</FileSystemAccessAllowedPaths> <FileSystemAccessAllowedPaths>*</FileSystemAccessAllowedPaths>
<FileSystemAccessAllowedPaths/>
 
The above is a code snippet from qlik web connectors deploy.config, I'm quite puzzled where the change has to be made so as to send file attachment through mail.
 
baarathi
Contributor II

Re: Access to path is denied. This can be changed using the FileSystemAccessAllowedPaths deploy conf

 
I could find the FileSystemAccessAllowedPaths tag in qlik web connectors deploy.config,  But I'm quite puzzled where the change has to be made so as to send file attachment through mail. @Gysbert_Wassenaar Can you please help me out some suggestions to work this out.
 
 
Baarathi
Thanks and Regards
 
 
 
 
MVP & Luminary
MVP & Luminary

Re: Access to path is denied. This can be changed using the FileSystemAccessAllowedPaths deploy conf

There are some examples in the deploy.conf file.

 <!-- 
  ******************************************************************************************************
  ********** This replaces the <AllowConnectorsFileSystemAccess> element in previous versions **********
  ******************************************************************************************************
  
  Some connectors can read/write to disk, this element lets you whitelist which paths the connectors are permitted to access.
    
  Notes:
  * Multiple paths should be delimitted with a semicolon (;).
  * If you want to white list ALL paths use a *
  * This setting applies across all connectors.
  * The account running the connector exe must also have permission to access any file in question.
  * Leaving it empty is equivalent to denying the connectors file system access.
  
  Some Examples:
  <FileSystemAccessAllowedPaths>c:\QWC\TempFiles;c:\SomeOtherDirectory</FileSystemAccessAllowedPaths>
  <FileSystemAccessAllowedPaths>c:\</FileSystemAccessAllowedPaths>
  <FileSystemAccessAllowedPaths>*</FileSystemAccessAllowedPaths>
  -->

Can you explain what you don't understand? All you need to do is copy one of the examples, add it below the comment section with the examples and change the path setting between the element tags.


talk is cheap, supply exceeds demand
baarathi
Contributor II

Re: Access to path is denied. This can be changed using the FileSystemAccessAllowedPaths deploy conf

Thank You... 🙂 I did not notice that lines were commented. Now it got solved.