Qlik Community

Qlik Connectors Discussions

Discussion Board for collaboration regarding Qlik Connectors.

agni_gold
Valued Contributor II

Re: POST Data using REST Connector

Hi,

How you are connecting to qliksense app and posting filters on the app using POSTMAN, can you please tell me some steps, i am trying but it is not happening.

Thanks,

vinothkumarr
New Contributor II

Re: POST Data using REST Connector

Hi Steve,

 

The information you provided is really useful and I could see to a level but i got stuck up in a place.

I am passing the HTTPHeader "Cookie" "<Cookie I received>"

It's throwing me a string error because my cookie is in the below format and contain " " in it which is recognized as the condition is closed as per qlik's statment. Also another issue that whenever a symbol or delimiter is available in the cookie Qlik is not considering and throwing me the error from the string where the delimiter starts.

Example: /YBpAQAAAAAAAAAAAAAu8P2AaQEAACwBC/ from the below cookie.

Cookie :  pajpm1-test="1QINAC7w/YBpAQAAAAAAAAAAAAAu8P2AaQEAACwBC/bPfLdV7BxxK8cTVP+6Xwx9zug="

Could you please help to rectify the same and get my code working.

Thanks in Advance,

Vinoth

 

vinothkumarr
New Contributor II

Re: POST Data using REST Connector

Hi Steve,

 

If i remove the "" I am receiving 'HTTPHeader' Expected 'CloseBracket' error.

 

Regards,

Vinoth

pascal_theurot
Contributor II

Re: POST Data using REST Connector

Hi Steve,

Which format do you have for you variable $(vRequestBody) ?

I'm not able to use it as it's always misinterpreted. I've tried many syntaxes.

syntax displayed during reloadtime (looks good) :

 

RestConnectorMasterTable:
SQL SELECT 
	"subjectId",
	"resourceId",
	"schemaPath",
	"__KEY_matrix",
	(SELECT 
		"access",
		"__FK_audit"
	FROM "audit" FK "__FK_audit")
FROM JSON (wrap off) "matrix" PK "__KEY_matrix"
WITH CONNECTION (
     BODY "{"resourceType" : "App.Object","resourceRef" : {"resourceFilter" : ""},
                "subjectRef" : {
                               "resourceFilter" : ""},
                "actions" : 46,
                "environmentAttributes" : "undefined",
                "resourceProperties" : ["name"],
                "subjectProperties" : ["id", "name", "userId", "userDirectory"],
                "auditLimit" : 100000,
                "outputObjectsPrivileges" : 4
}"
    )

but I get the following error message (seems to be partially interpreted and truncated) :

Connector reply error: Unknown substring, string, or value at (12,28): 
'.Object","resourceRef" : {"resource'

We'll, if you have some suceedeed method, it could help.

Regards

Pascal

 

Pascal