Qlik Community

Qlik Connectors Discussions

Discussion Board for collaboration regarding Qlik Connectors.

Contributor III

Problem loading JSON Eurostat data

Hi community,

I am trying to load JSON data from Eurostat. I have problem because the values are not stored in an array but in an object.

"value" : { "0": 1.3587, "18": 1.5849 }

The REST connector uses the "0" and "18" as fields but what I need is to have two fields - index and value.

What REST connector gives me:



What I need:



I tried to load a different dataset which stores values in an array [] and this worked as expected.

Is there a way to force REST connector to load values this way?




Tags (3)
Labels (3)
1 Reply

Re: Problem loading JSON Eurostat data

You should be able to use the CrossTable function to transform the data.

And the rest connector is actually correct in loading the data the way it does. The json you posted does not have an "index" field. There's no way that I know of to make the rest connector ignore the json specification and apply an arbitrary other definition for parsing the json data.

talk is cheap, supply exceeds demand
Community Browser