Qlik Community

Qlik Connectors Discussions

Discussion Board for collaboration regarding Qlik Connectors.

geoffatcroda
Not applicable

Sharepoint 365 connector not working through a proxy server

Hi all,

I am attempting to use the Web Connector 2.1.0 SharePoint 365 connector on a server and it is proving quite difficult. The SharePoint connector is working fine when running on a desktop machine, I think because of single sign on, but when I put it on a server we have issues. I can still connect to the SharePoint environment with no issues at all but when I try it with the connector following this guide Office 365 Sharepoint Connector For QlikView And Qlik Sense - QVSource: The QlikView & Qlik Sense AP...  it throws up an error:

Web Connector Error.PNGLooking around on the web it seems to suggest that it's not able to connect to SharePoint but I cannot tell if it is something to do with the proxy or the connector itself.

The same method above works as soon as I take it off the server.

Does anyone have any suggestions that I can try out or any advice?

Thanks,

Geoff

4 Replies
chrisbrain
Not applicable

Re: Sharepoint 365 connector not working through a proxy server

Hi - That sounds to me like something is blocking the outbound connection between the server login.microsoftonline.com.

Are you able to remote desktop into the server and reach login.microsoftonline.com in a browser? Do you know if there is a firewall or proxy between the server and internet?

geoffatcroda
Not applicable

Re: Sharepoint 365 connector not working through a proxy server

Hi Chris,

Sorry for the late reply,

I can navigate to the SharePoint site fine and when I am using the web connector to authenticate it gives me the Authentication Code. Only when I try to save the Authentication Code it gets the error.

There is a proxy we are using to connect from the server to the internet and we have had to add some exceptions in order to get it to this point. I have also enabled the proxy for the web connectors, thought that may have been the issue to start with.

It is almost as if the web connector itself is struggling to use the proxy server in order to communicate.

Thanks for your help,

Geoff

chrisbrain
Not applicable

Re: Sharepoint 365 connector not working through a proxy server

Hi - Have you ensured the proxy allows connections from the connectors to the endpoints listed on the about tab for the connector?

geoffatcroda
Not applicable

Re: Sharepoint 365 connector not working through a proxy server

Hi Chris,

I did not see this section before, I've forwarded the urls on to our network guy so I hope that it will be it.

Thank you very much!

Geoff