Qlik Community

Ask a Question

Qlik Design Blog

All about product and Qlik solutions: scripting, data modeling, visual design, extensions, best practices, etc.

Yianni_Ververis
Employee
Employee

Qlik_BOT_Headers_Skype.jpg

Last month I talked about our new QlikBotNode, setting it up and getting it ready for Telegram Qlik Sense Bot with Node.js and Enigma.js.

Today, I will talk about the steps needed to make your bot available for Microsoft Skype as well!

Assuming that you have already forked the code from GitHub - qlik-bots/QlikBotNode: QlikBotNode is a server build in Node.js, Express.js, Enigma.js and ...and you have already went through the previous tutorial and set up the Telegram bot.


Installation


  • First you need to "Register a Bot with Bot Service". Login to the Azure Portal http://portal.azure.com/
  • Click the New button found on the upper left-hand corner of the Azure portal, then select AI + Cognitive Services > Bot Channels Registration.
  • Click the Create button to start the creation process.

registration-create-bot-service-blade.png

  • Enter a Bot Name as you want to appear in your contact list
  • You can use the free Pricing Tier for testing
  • For the Messaging Point add you full route like https://{your-server}/api/sense-bot/microsoft/
  • You can skip the Application Insight for now
  • Once registered, go to settings and get the AppId and the Password. You will need to add them in your environmental variables

registration-settings-manage-link.png

  • Click on Manage to get the password

registration-generate-app-password.png

  • Put the AppId and Password in your Environmental variables.
  • For Windows, go to "Control Panel" -> "System" -> "Advanced System Settings" -> "Environment Variables"
  • - For Linux, from your directory (~), type "nano .bash_profile" or "vim .bash_profile" and enter the variables there like
  • export SKYPE_BOT_ID_SCV=''
    • export SKYPE_BOT_PASSWORD_SVC=''
  • While still in settings, go to "channel" and add skype.


Thats it!


For more Details on Register a bot with Bot Service (https://docs.microsoft.com/en-us/bot-framework/bot-service-quickstart-registration)


Usage


  • Type help for all of the available commands.

chat-help.png

  • Click on Salesforce to get the available commands for the Salesforce App and then click on the Dashboard to get a list of KPIs

chat-salesforce.png

  • Click on CIO Dashboard and then on Management

chat-cio.png

  • - If you want to change your language click on Language and select one of the available ones. So far we have only 3, English, Spanish and Greek but please feel free to add as many more as you want

chat-language.png

That's it!

Make sure you follow:

Best,

Yianni

28 Comments
Yianni_Ververis
Employee
Employee

If you want to use telegram, follow the instructions.

https://github.com/qlik-bots/QlikBotNode/blob/master/docs/Telegram.md

Otherwise, comment out the telegram routes (L11 & L14) and it will not load

https://github.com/qlik-bots/QlikBotNode/blob/master/app/server/routes/api/sense-bot.js

0 Likes
2,800 Views
Yianni_Ververis
Employee
Employee
0 Likes
2,800 Views
ChristopheG
Contributor II
Contributor II

Thanks for the reply, I have tried commenting out these lines but then I get the following error:

error: uncaughtException: express.router is not a function

0 Likes
2,895 Views
vikraant
Creator
Creator

Hi Yianni,

I have followed the steps in docs and tested it using Microsoft botframework emulator.  Bot is working fine on localhost.

I tried to configure the bot to work on the public domain by changing the localhost to public ip address

1. config.json

2. server.js

I have put the exported certificate in the '..\QlikBotNode-1\app\server\certs'  folder.

I have also downloaded ngrok to test the bot on remote computer.

Still no success yet.

Am I going in the right direction?

Thanks & Best Regards,

Vikraant

2,895 Views
Yianni_Ververis
Employee
Employee

Yes

The certs folder name needs to be the same as your server dns

0 Likes
2,895 Views
vikraant
Creator
Creator

I also tried putting the messaging endpoint in the Azure Bot Channel settings

(https://<ip-address>:3443/sense-bot/microsoft/api)  .

When I put the above address in the browser I am getting following error

error.PNG

0 Likes
2,895 Views
Yianni_Ververis
Employee
Employee

This is the public accessible page. That means that you have not setup the routes correctly

I believe it should be

https://<ip-address>:3443/api/sense-bot/microsoft/

0 Likes
2,895 Views
vikraant
Creator
Creator

Hi Yianni,

I am sorry. I have put the following address  https://<ip-address>:3443/api/sense-bot/microsoft/.

Still getting the same error. error.PNG

I have downloaded version 1 of  QlitBotNode

https://github.com/qlik-bots/QlikBotNode/tree/v1

0 Likes
2,895 Views
vijetas42
Specialist
Specialist

Great Stuff! can you please suggest on registering BOT on azure portal. It seems to be paid. is there anything which we can use as trial for free.

Regards,

Vijeta

0 Likes
2,799 Views
nikhilgarg
Specialist
Specialist

Hey Jagan,

Will this bot works with Skype or with Skype for business?

0 Likes
2,799 Views