Qlik Community

Qlik Fix

Here you'll find the recordings of our Qlik Fix video series.

Announcements
QlikWorld happening right now! You can still join: REGISTER NOW

Qlik Fix: How to Fix Connection Lost Error

cancel
Showing results for 
Search instead for 
Did you mean: 
Troy_Raney
Digital Support
Digital Support

Qlik Fix: How to Fix Connection Lost Error

Attachments

Qlik Fix Banner 1000 pixel_Nail_rich color.png

 

This video is part of the Qlik Fix Video series. If you found this video useful, check out the other Qlik Fix Videos.

This video explain how to configure a Web Socket Ping Interval setting on Qlik Sense to help resolve Connection Lost errors in the hub or script editor.

Here is a link to more information in the Support Knowledge Base:
https://qliksupport.force.com/articles/000055708

Attached is a downloadable .mp4 video file for those who cannot view YouTube videos.

Comments
QFabian
Specialist II
Specialist II

👍

@Troy_Raney 

0 Likes
vegard_bakke
Partner
Partner

To help you debug what might cause the Connection lost, I have forked and extended https://github.com/flautrup/QlikSenseWebsocketConnectivityTester,  by including additional inactive websockets.

Hopefully, the times that this web page reports, might help you identify the actual cause for why the websockets drop.

Download from: https://github.com/vbakke/QlikSenseWebsocketConnectivityTester

JohnLBevan
Contributor
Contributor

FYI: We also had this issue after introducing a NetScaler (load balancer / firewall) in front of the service; with the error showing the moment the site was loaded.

The cause there was down to how web sockets are treated by the NetScaler. Detail  and fix here: https://support.citrix.com/article/CTX206986

Their proposed solution:

Recommended the customer to enable "Websocket Connection" in default http profile or by creating a new http profile and enabling that option. Then bind the new http profile to Netscaler Gateway vserver.
vegard_bakke
Partner
Partner

Also, make sure you turn up the "kill idle websockets" from the default value. 
I think Netscaler terminates idle websocket after 2 minutes,  and Azure Gateway does the same after 4 minutes. 

JohnLBevan
Contributor
Contributor

@vegard_bakke good shout.  I had a look around whilst trying to find a good value to set that to, and stumbled across a TCP Keep Alive setting, which allows QlikSense to change how often the client connects / presumably setting this would satisfy the netscaler/gateway:

https://community.qlik.com/t5/Knowledge/Enabling-TCP-Keep-Alive-Functionality-In-Qlik-Sense/ta-p/171...

If I've understood the article correctly, for most browsers the default settings should mean that users don't hit this issue (as the client's keep alive values are smaller/more frequent than the loadbalancer/firewall's timeout).  However, users with FireFox may have issues (since the keep alive changes to once every 10 minutes after the first 2 mins), or if someone disabled the keep alive option by setting the `WebSocketPingInterval` to 0, or to a much higher value.

Setting `WebSocketPingInterval`  to `60 ` seems a suitable fix for all browsers.

Full details of where to find this setting / how to apply the fix on the above link.

0 Likes
Version history
Last update:
‎2019-02-15 07:23 AM
Updated by: