Qlik Community

Qlik GeoAnalytics Discussions

Discussion Board for collaboration regarding Qlik GeoAnalytics.

Announcements
BI & Data Trends 2021. Discover the top 10 trends emerging in today. Join us on Dec. 8th REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

Erorr when loading multi polygom with GeoAnalytics connector

Hi,

We try to load data from a open ArcGis environment. Some of the results contain multi polygon's. When we load the data through the GeoAnalytics connector we get the following error:

Connector reply error: QVX_SYNTAX_ERROR: Failed to process query: Failed to create dataset Dataset: Expected property named "fields" in esri json file.

Data source: http://mapservices.prorail.nl/arcgis/rest/services/Gebiedsindelingen_ProRail_006/MapServer/11/query

The result is that all rows are loaded, the rows with a single polygon contain geo data, the rows that contain multi polygon's are missing the geo data.

How can we fix this?

Thanks,
Frank

 

 
 

 

 

 

 

1 Solution

Accepted Solutions
Highlighted
Employee
Employee

The connector can only load one geometry type at the time, it's not possible to mix.

Maybe it is possible to force Esri to return one type at the time?

Thanks,

Patric

View solution in original post

3 Replies
Highlighted
Employee
Employee

The connector can only load one geometry type at the time, it's not possible to mix.

Maybe it is possible to force Esri to return one type at the time?

Thanks,

Patric

View solution in original post

Highlighted
Partner
Partner

Hi Patric,

Maybe it is a different issue then I described. 

ArcGis : http://mapservices.prorail.nl/arcgis/rest/services/Gebiedsindelingen_ProRail_006/MapServer/3/query

If check rows where NUMMER = 18 NUMMER = 20, ArcGis gives me the next result:

ArcGIS result.png

I create a JSON url for the complete set:
http://mapservices.prorail.nl/arcgis/rest/services/Gebiedsindelingen_ProRail_006/MapServer/3/query?w...

When I load this url using the GeoAnalytics connector I get the following result where you can see there is no shape information for  NUMMER ={18,20} (and a couple of others)

GeoAnalytics result.png

Do you know why some info is missing?

Frank

 

Highlighted
Employee
Employee

Hi Frank,

Odd, it works for me. I specified the service to output NUMMER,NAAM,PCA in NUMMER order:

http://mapservices.prorail.nl/arcgis/rest/services/Gebiedsindelingen_ProRail_006/MapServer/3/query?w...

And then "Load" with the QGA connector EPSG:28992, EsriJson, Polygon, NUMMER as keyfield.

See the sample app.

Thanks,

Patric