Qlik Community

Qlik GeoAnalytics Discussions

Discussion Board for collaboration regarding Qlik GeoAnalytics.

Highlighted
Partner
Partner

GeoAnalytics Connector Error

Hello,

 

I am getting this error when try to use the Qlik GeoAnalytics connector:

Anyone can help me? Thanks in advance...

 

[Details]

- GeoAnalytics Connector Error / Bad Response / Could not parse response from server

- The extensions are working fine

- Version: september 18 (same as qlik sense server)

- I get "OK" when I Teste connection with Auto option

- Default server url: http://xxxxx.eastus.cloudapp.azure.com/ (same as the url I use to access qlik sense server)

- IdevioGeoAnalyticsConnector.exe.config in C:\Program Files\Common Files\Qlik\Custom Data\QvIdevioConnector:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
<startup>
<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5.2"/>
</startup>
<appSettings>
<add key="serverURL" value="http://xxxxx.eastus.cloudapp.azure.com/"/>
<add key="cloudURL" value="https://ga.qlikcloud.com"/>
<add key="licenseKey" value="*******************************************"/>
<add key="localServerInstallationPath" value="C:\Program Files\Common Files\Qlik\Custom Data\QvIdevioConnector\lib"/>
<add key="localServerPort" value="42024"/>
<add key="locationServerPath" value="https://ga.qlikcloud.com"/>
<add key="routeServerPath" value="https://route.qlikcloud.com"/>
<add key="geocoderServerPath" value="https://geocode.qlikcloud.com"/>
<add key="geoAnalyticPlusTimeout" value="7200000"/>
<add key="geoAnalyticUseSystemProxy" value="true"/>
<add key="geoAnalyticMemory" value=""/>
<add key="geoConnectorVersion" value="September 2018"/>
</appSettings>
<system.web>
<membership defaultProvider="ClientAuthenticationMembershipProvider">
<providers>
<add name="ClientAuthenticationMembershipProvider" type="System.Web.ClientServices.Providers.ClientFormsAuthenticationMembershipProvider, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=***************" serviceUri=""/>
</providers>
</membership>
<roleManager defaultProvider="ClientRoleProvider" enabled="true">
<providers>
<add name="ClientRoleProvider" type="System.Web.ClientServices.Providers.ClientRoleProvider, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=*****************" serviceUri="" cacheTimeout="86400"/>
</providers>
</roleManager>
</system.web>
</configuration>

 

2019-03-18_12-18-07.png

 

2019-03-18_12-34-33.png

Labels (2)
3 Replies
Employee
Employee

Re: GeoAnalytics Connector Error

Ok, that's strange, do you get the same response using "Custom" and entering the url in the dialogue? Any more error message in the JS console or in the connector logs?

Thanks,
Patric
Partner
Partner

Re: GeoAnalytics Connector Error

I put Custom https://ga.qlikcloud.com and got OK.

Now the connector is working

I didnt realize that the default server url in installation proccess is the url from geo analytics server... My bad!

Thanks in advance

Support
Support

Re: GeoAnalytics Connector Error

Hi @igorfernbi ! If this issue is resolved, please  mark the correct response as "Solved". 

Help users find answers! Don't forget to mark a correct resolution 🙂