Qlik Community

Qlik GeoAnalytics Discussions

Discussion Board for collaboration regarding Qlik GeoAnalytics.

Highlighted
mazenbilto
New Contributor II

Geoanalytics server - changing the default server for geoanalytics extensions

Hello qlik community

 

We have installed the qlik geo analytics server and the extensions (graphical gadgets) on our server. We followed the installation guide on how to do that.

https://bi.idevio.com/wp-content/qlik/QlikGeoAnalyticsServerInstallationGuide.pdf

the issue we have is regarding point 7 point 8 in the link above.

Everything is up and running and there are no issues except the mentioned above.

When we go to the "settings.js" to change the ideviomap default server it always shows a 404 error on the map that it couldnt find the server.

however when we take the same link and put it manually on the map it can reach the geoanalytics server. It's just that when we put the same link in the Define function in the settings.js file nothing shows up.

also the server URL field in the Geomap widget is empty by default if that means anything.

keep in mind the following.

1- on our qliksense server we dont have HTTPS protocol enabled. (although we enabled HTTP for qliksense and tried it still didnt matter)

2- the port is 8080.

3- the qlik sense enterprise server, the geoanalytics tools/extensions and the geoanalytics server are on the same server. We are tried using http://localhost:<portnumber> this didnt work. we tried using http://<servername>:<portnumber> still doesnt work.

 

please help, thanks in advance.

Mazen.

Labels (1)
3 Replies
Employee
Employee

Re: Geoanalytics server - changing the default serer for geoanalytics extensions

Sounds like there might be something wrong in the edit.
Alternatively, change the <Text Label="Server URL:" Type="text" Expression="http://you.server.com"/>
in the Definition.xml in the IdevioMap folder.
mazenbilto
New Contributor II

Re: Geoanalytics server - changing the default serer for geoanalytics extensions

Hello Patric

thanks for your reply. I'm so sorry I made a mistake in the original post. its point 8 we are trying to use not 7.

as for trying to change the xml file. if this is still relevant, can you please tell me how the file should look like in the end? there is a bit of text in the file and we didn't know how to position the change. We tried a couple of setups but none worked.

thanks again and sorry about the mistake.

Mazen

Employee
Employee

Re: Geoanalytics server - changing the default serer for geoanalytics extensions

ok, some hints:
* For Qlik Sense server use the settings.js to modify the map server url. (xml part was only for QV).
* Specify the full url: https://your.map.server.com:port
* Make sure the port is not occupied by anoyther process.
* Use a valid certificate, self signed won't work.
* The map server must be accessible from the client browser.
* https://your.map.server.com:port/ravegeo/status should return "ok" and valid certificate when trying out in the client browser.
* Check with F12 in the browser that you modified the correct settings.js file.

Thanks,
Patric