Qlik Community

Ask a Question

Qlik GeoAnalytics Discussions

Discussion Board for collaboration regarding Qlik GeoAnalytics.

Announcements
Join us March 10th, 7 Ways Modern Analytics Can Help You Take Smarter Action. REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
beunderf
Partner
Partner

How to configure the proxy for the connector?

Hi all,

We installed GeoAnalytics with our customer, but we have one issue. When we try to use the connector we get the following error:

We have Internet access, We can browse the Internet but the connector needs proxy settings apparently.

Thanks in advance

1 Solution

Accepted Solutions
Jonas_Linden1
Employee
Employee

The solution working was adding this to the config file:

  <system.net>

    <defaultProxy useDefaultCredentials="true" enabled="true">

      <proxy usesystemdefault="False" autoDetect="False" proxyaddress="http://proxy:8080" />

    </defaultProxy>

  </system.net>

How to get an Authenticated Proxy Server working properly from ASP.NET app? - Stack Overflow

View solution in original post

11 Replies
beunderf
Partner
Partner

If found the following information (below), I tried this and we do get the message ''Welcome to your friendly GeoAnalytics servlet", but when click on 'Test Connection' we keep getting the 'Connection faild' error.

Qlik GeoAnalytics utilises Qlik web services hosted at qlikcloud.com (by default).

To verify web services are accessible from client do the following:

  • On the machine where Qlik GeoAnalytics are installed open a browser and go to

https://ga.qlikcloud.com/ravegeo/geoanalytics/api/testConnection?version=1.1

  • ​On a successful connection the following message will be displayed

"Welcome to your friendly GeoAnalytics servlet.

Jonas_Linden1
Employee
Employee

Hi Frank,

I believe one solution that should work would be to change the IdevioGeoAnalyticsConnector.exe.config

found here :\Program Files\Common Files\Qlik\Custom Data\QvIdevioConnector

If you look at the https://docs.microsoft.com/en-us/dotnet/framework/configure-apps/file-schema/network/defaultproxy-el...

and add something similar to this to the config file (with your proxy address and port)

   <system.net> 

    <defaultProxy> 

      <proxy 

        usesystemdefault="true" 

        proxyaddress="http://192.168.1.10:3128

        bypassonlocal="true" 

       /> 

    </defaultProxy> 

  </system.net> 

</configuration>

If you installed the Connector on multiple servers you need to change the config file for all.

Please let us know if this solves the problem.

Kind Regards,
Jonas

beunderf
Partner
Partner

Hi Jonas,

We added the information to the config file, but the first time we miss typed the proxy address. Then we received the following error.

When we corrected the type error in the proxy address we get the original error again:

So we know it is using the right proxy server, but it looks like the authentication is not correct. In this organization they use automatic Windows Authentication. Is there a way to tell the connector to use windows authentication when it tries to use the proxy?

What I also don't understand, there is a 'Qlik' and a 'Qliktech' folder in Common files which both contain the QVidevioconnector. Do you know why this is?

'

beunderf
Partner
Partner

Hi  bps or jonas.linden‌, Do you have any idea how to move forward in solving this issue 😞

Jonas_Linden1
Employee
Employee

Frank,

a quick question have you tried with adding useDefaultCredentials?

        <defaultProxy
     enabled="true|false"
     useDefaultCredentials="true|false"
     <bypasslist>
</bypasslist>
     <proxy></proxy>
     <module></module>
   />

<defaultProxy> Element (Network Settings) | Microsoft Docs

Jonas_Linden1
Employee
Employee

Hi Frank, When you are testing the connection to the QGA Connector a log file is created. :\ProgramData\QlikTech\Custom Data\IdevioGeoAnalyticsConnector\Log Do you see anything in that log file?

Jonas_Linden1
Employee
Employee

The solution working was adding this to the config file:

  <system.net>

    <defaultProxy useDefaultCredentials="true" enabled="true">

      <proxy usesystemdefault="False" autoDetect="False" proxyaddress="http://proxy:8080" />

    </defaultProxy>

  </system.net>

How to get an Authenticated Proxy Server working properly from ASP.NET app? - Stack Overflow

View solution in original post

mirasifali
Contributor II
Contributor II

HI Jonas,

Could you please confirm above lines to be added to which config file ? Are we taking about the Qlikview config.xml file or is it the asp web.config file ?

Regards,

Asif.

Patric_Nordstrom
Employee
Employee

Hi,

Cchange the IdevioGeoAnalyticsConnector.exe.config found here :\Program Files\Common Files\Qlik\Custom Data\QvIdevioConnector

Thanks,

Patric