Qlik Community

Qlik GeoAnalytics Discussions

Discussion Board for collaboration regarding Qlik GeoAnalytics.

jayantyad
New Contributor

Not able to Execute Where Exists ([Customer Number]) in Test Data??

Hi All,

I was following through the free tutorial provided on the QLIKVIEW Website:

Build your First Qlikview Document_Extract, Transform and Load.

LINK:

Extract, Transform, and Load

The Dataset contains data from 5 Files that are, salesdata, Customers, CustomerAddress, Region and Division.

In the later part of t eh video, the instructor has provided the steps to include only those Customer Number from the Customer dataset that are already present in the other dataset.

For this purpose where exists query was used in the script mode.

Please find below the screenshot from the video:

Query used in the Video: Where Exists ([Customer Number]);

Image 1.png

However when I tried the same, I faced the issue that View in the Table Viewer changed and I was not able to link Customer number Attribute to Customer and Customer Type attribute.

Please find below the Screenshot of before this condition was put in the query:

Image 2.png

Screenshot after this condition was put in the query:

Image 3.png

Can someone help me in understanding that why I am not able to link the Customer number with Customer and Customer Type after the where exists query was used for Customers Dataset.

I followed the instructions in the Video (link provided above) and it is working Fine in the Video

Tags (1)
1 Reply

Re: Not able to Execute Where Exists ([Customer Number]) in Test Data??

Would you be able to share the app you are testing this on or the excel files from where you are running this? Above you shared just the Customers table, can you share the script for salesdata also where you might have the  Customer Number field against which you might be doing the where exists?

Community Browser