Qlik Community

Qlik GeoAnalytics Discussions

Discussion Board for collaboration regarding Qlik GeoAnalytics.

10245jngray
New Contributor

Qlikview GeoAnalytics Server Question

We're new to the GeoAnalytics server, and while I've done the full install, and installed the extensions and connector for the desktop version, I keep running into a "Error connecting to server (404)" message whenever I try and add a map to my application.  I know this is because I don't have the right server path when I tried to install the connector.  This is because even though all of the documentation says to update the path to set it to the URL of the local server instead of the default server, no documentation actually tells me what this path is so I've tried different variations on https:localhost/ravegeo.server.com, https://localhost/ragegeo/server, https://[servername]/ravegeo....... and it's still not connecting.

Does anyone actually have what that darn path is rather than just a reference to the "local server URL"?

5 Replies
Highlighted
Employee
Employee

Re: Qlikview GeoAnalytics Server Question

Hi Jennifer,

The server url should be protocol://hostname:port (if different port than 80)

For example:

https://maps.qlikcloud.com

http://myserver

http://myserver.mydomain.com:8001

Please check that the server is visible from the client, often firewalls prevents users from accessing.

A tip is to use Sense in the browser http://localhost:4848/hub/my/work

and then open the JS console (F12) to see check why connection fails.

Thanks,

Patric Nordström

Qlik

kevinpintokpa
Contributor II

Re: Qlikview GeoAnalytics Server Question

We're running into this same problem.  The GeoAnalytics server claims to have installed successfully but we can't find it and no URL to it works.  Did you figure this out?

Employee
Employee

Re: Qlikview GeoAnalytics Server Question

Hi,

After install, make sure you can login in to the server.  Do this login also from a client computer where you want to run QGA not just on the server. It's essential that the map server is visible form the client.

http://myserver/ravegeo/admin

If this works the url to the server is http://myserver

This type problem is normally due to that the right ports to server has not been opened.

If you for instance install the map server on port 81 because port 80 (normal http traffic) is occupied, then port 81 must be opened in the firewall and accessible from the client. Test using

http://myserver:81/ravegeo/admin


If this works the url to the server is http://myserver:81

Thanks,

Patric Nordström

Qlik

Partner
Partner

Re: Qlikview GeoAnalytics Server Question

Hi Jennifer,

I faced the same issue but i could resolve it. What i observed was

if you are accessing QS via https  then url of GeoAnalytics has to be https.

If QS accessed via http then url of GeoAnalytics can be http.

The url to be given is http://geoanalyticsserverurl:port.

You should also ensure you make the relevant entry in the settings.js file in the ideviomap extension folder.

define(

{

"server": "http://geoanalyticsserverurl:11000/"

}

);

Hope this resolves your query.

Regards,
Ganapati.

Partner
Partner

Re: Qlikview GeoAnalytics Server Question

Hi,

Isn't it possible to run Qlik Sense on HTTPS and GeoAnalytics (GA) on HTTP?

For my case, I tried to generate the GA server certificate from Qlik Sense QMC. Then updated the GA settings to enable SSL. Then restarted the GA service. Now, GA can't be accessed neither on HTTP nor on HTTPS. Checked the GA server and found out that the GA server stops listening to both ports (8080-HTTP & 443-HTTPS).

If I disable SSL and restart service, then GA can work properly on HTTP.

So, the certificate generated by QMC for GA server won't work? We need to buy the trusted certs only?

Regards,

Hardeep