Qlik Community

Qlik GeoAnalytics Discussions

Discussion Board for collaboration regarding Qlik GeoAnalytics.

Announcements
QlikWorld, June 24-25, 2020. Free virtual event for DI and DA gurus.Register Today
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Luminary
Luminary

Trouble loading geojson polygons

Hi Everyone,

I'm trying to load a GeoJSON file (http://www.rfs.nsw.gov.au/feeds/majorIncidents.json) that contains both point and polygon data. I can't seem to work out a way to load the polygons using the GeoAnalytics connector. Regardless of what option I use for the expected geometry type only the points are loaded. I don't know how the connector differentiates between the geometry types in the json file so I can't work out how to configure this correctly. Does anyone have any ideas that might point me in the right direction?

Thanks,

Rod

Labels (2)
1 Solution

Accepted Solutions
Highlighted
Employee
Employee

Re: Trouble loading geojson polygons

Usually works to first load areas and then points in a second call. But nested geometry collection can be tricky. 

An option is to make a rest connection and stitch together the points and the multi polygons, see the load script.

Thanks,

Patric

View solution in original post

3 Replies
Highlighted
Employee
Employee

Re: Trouble loading geojson polygons

Usually works to first load areas and then points in a second call. But nested geometry collection can be tricky. 

An option is to make a rest connection and stitch together the points and the multi polygons, see the load script.

Thanks,

Patric

View solution in original post

Highlighted
Luminary
Luminary

Re: Trouble loading geojson polygons

Thanks Patric, I'll give it a go when I'm back with access to my server tomorrow (Australian time). I've tried loading either points or polygons first, but specifying either just gives me an error. Auto returns only the points, but when you are mapping bushfire areas I really need those shapes.

Cheers,

Rod

Highlighted
Luminary
Luminary

Re: Trouble loading geojson polygons

A big thank you @Patric_Nordstrom , I didn't realise you had provided that example with the file I was working with, I assumed you were just providing me an example. I really appreciate that.

Cheers,

Rod