Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Not applicable

Autosum not working

Hi, I've hit an excel issue with the Sum() function. When I use it on the data i get e.g. £ - but if I add the cells manually it works. Please see below image for what the issue looks like. I've tried various combinations on the template/QV document of number/currency etc.

this is a screen shot taken from the previewed template.

ExcellAutoSum.PNG

Thanks for any help

Tags (2)
1 Solution

Accepted Solutions
marcus_sommer
Not applicable

Re: Autosum not working

I think the reason is that your values aren't numeric else strings and by adding them manually together you start an automatic conversation which didn't apply by using the sum-function.

If you want to load these data then into qlikview you will be very probably need some transforming on the data so that they will be interpreted as numbers, maybe something like this:

num(keepchar(YourField, '0123456789,')

and further have a look on The Crosstable Load to transform the datastructure of your table.

- Marcus

2 Replies
marcus_sommer
Not applicable

Re: Autosum not working

I think the reason is that your values aren't numeric else strings and by adding them manually together you start an automatic conversation which didn't apply by using the sum-function.

If you want to load these data then into qlikview you will be very probably need some transforming on the data so that they will be interpreted as numbers, maybe something like this:

num(keepchar(YourField, '0123456789,')

and further have a look on The Crosstable Load to transform the datastructure of your table.

- Marcus

Not applicable

Re: Autosum not working

Yes, the data is in Text format,

Thanks a lot.

- itsdanny

Community Browser