Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Read about the latest Qlik Community enhancements on the Community News blog!
cancel
Showing results for 
Search instead for 
Did you mean: 
jvk_sharma
Creator III
Creator III

Date formatting issues.

Hi ,

I have a straight table in qlikview and I am generating the reports in Nprinting as pivot table (converting straight table to pivot by using excel in nprinting)as it is not possible to incorporate the pivot table from qlikview to nprinting directly.

Now I am having the formatting issues for the date.

i have tried the other possible formats to change but i am unable to do that.

Any help is appreicated.

This is the code i am using in qlikview .

Date(MonthStart("recorded_at"), 'MMM/YYYY') as "Month/Year"

you can see in the figure 1 .it has formatted accordingly.

But in the figure 2 i am unable to get those even after formatting the cells .

services.pngservices.png

1 Solution

Accepted Solutions
Daniel_Jenkins
Support
Support

Hi Vamsi,

As mentioned in the article you linked to you should not check Keep source formats. Use Excel formatting instead.

Straight table in QlikView:

Follow How to Create a Pivot Table from Excel Table Columns

Then format in Excel:

Output:

HTH - Daniel.

View solution in original post

18 Replies
Anil_Babu_Samineni

May be using this


Date([Service Sttributes],'MMMYYYY') as [Service Sttributes]

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
Anonymous
Not applicable

either you set the cell format of your excel template or activate "keep source format".

Have a look here, section: Add Object as Table and Change "Keep Source Formats"

How to Create a Pivot Table from Excel Table Columns

jvk_sharma
Creator III
Creator III
Author

I am able to get in qlikview . but not in n printing.

The expresssion above i have used is working fine.

kakaderanjit53
Creator III
Creator III

Hi Vamasi Krishnna,

just check the checkbox under the property option of table i.e. on left hand side in Nprinting

"keep source format" must be selected

jvk_sharma
Creator III
Creator III
Author

Hi ,

sorry i cant find it .

Can you send a pic pls.

Anonymous
Not applicable

, you will find it in the report editor...

Have a look here, section: Add Object as Table and Change "Keep Source Formats"

How to Create a Pivot Table from Excel Table Columns

jvk_sharma
Creator III
Creator III
Author

I cant see many properties.Why??

services.png

jvk_sharma
Creator III
Creator III
Author

Sorry my mistake .I should add it to the table not to the level. Let me try.

Stephen_Jasionowski

You need to add the object to the Tables instead of the level. Right click on Tables and add CH08.