Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Read about the latest Qlik Community enhancements on the Community News blog!
cancel
Showing results for 
Search instead for 
Did you mean: 
rviel_dubo
Contributor III
Contributor III

Expression not showing in excel report

Hi everyone,

I've got this expression in my chart that won't show in the Excel report.

Sum({<OXFMode = {"R","S"}, OXFRMonthSEQ = {"-1"}, OXFSMonthSEQ = {"<-1"}> +
             < OXFCurrInTransit = {'1'}, OXFOpenShip_Seq = {'>-1'}>} OXFShpAmount)

We are using Nprinting 16.5 and QlikView version 11.2 SR6.

I was wandering if it was because I was using 2 set analysis within the same expression but I couldn't find any docs on it.

Any hint would help.

 

Thanks.

 

Robert Viel

Labels (2)
1 Solution

Accepted Solutions
rviel_dubo
Contributor III
Contributor III
Author

Hi Everyone,

 

Deleted nsq file and restart anew and it does work now.

 

Case close, Thanks

View solution in original post

5 Replies
Lech_Miszkiewicz

Hi,

can you elaborate little bit more:

  • how you try to use this expression?
  • do you mean that it doe not work or is not even available in NPrinting template editor?
  • do you try to use it as a date column? 
  • what is the label of this expression in the chart - is there any other label with the same name/value (repeated expression labels cause expressions to disappear in Nprinting)
  • maybe you have a LF (line feed) character in your expression and when you try to drag and drop tag to your template it is not fully transfered

There is nothing unusual about your expression so the fact that you have 2 sets does not mean anything. It is very basic expression..

Providing screenshots would help me understand context of your query. Right now I am bit confused what is not working; whether your chart does not work, or whether expression which should come as column does not appear in your tag list or whether it is something else.

 

regards

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Lech_Miszkiewicz

btw...also give us little bit more context if there are any task, report or maybe object or recipient filters used which may exclude values....

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
rviel_dubo
Contributor III
Contributor III
Author

Hi Lech,

Expression is working fine within QlikView as show in this picture.

Expression label is "Total Shp"

QlikView App.jpg

My Problem came when I was creating a totally new report in Nprinting, no task, no filter yet.

Template.jpg

As always, after adding a chart to my template I do a quick preview and this was the result

Preview.jpg

 The expression is not showing within NPrinting and I just can't figure out why.

This is the first time something like this happen to me, everything seems fine, nothing out of the extraordinary, simple chart. what can go wrong .... except ...

Here I am, reaching out for you guys 🙂

rviel_dubo
Contributor III
Contributor III
Author

Hi Everyone,

 

Deleted nsq file and restart anew and it does work now.

 

Case close, Thanks

View solution in original post

Lech_Miszkiewicz

Well. Strange, but i am glad it works. Cheers

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.