Qlik Community

Ask a Question

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Join us at the Cloud Data and Analytics Tour! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
Ri_ta
Partner
Partner

Filter Error NPrinting June 2019

Hey guys,

I'm trying to generate a report in Qlik NPrinting (connected to a QS app, QS version june 2019, Qlik NPrinting version june 2019), excel template.

The report has 2 filters: the month (Nov, filter set to "Value is" and 2019, filter set to "Numeric Value is"). 

When I try to preview the report (with the on-demand button) in pdf I get this error message:

x.PNG

Also, in my QS app all objects have values, but when imported to NPrinting all graphs and tables have no values.

I have other report connected to the same app, where I also apply a filter and it works just fine.

 

Can you help me?

Thanks!

Labels (2)
7 Replies
Ruggero_Piccoli
Employee
Employee

Hi,

It seems that you are applying incompatible filters. In the text you told that you have a report filter with Month = Nov and the screenshot says you are applying the filter Month = Sep, maybe it comes from a selection in the Qlik Sense app. 

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Ri_ta
Partner
Partner
Author

Hi Ruggero, 

I also tried to apply the filter "Nov". I get the same error.

Ruggero_Piccoli
Employee
Employee

Hi,

If you remove the filters?

Then try to re-apply them one-by-one.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Ri_ta
Partner
Partner
Author

If I remove the filters I'm able to preview the report, but the graphs have no values.

I also tried to re-apply them, one by one. Still get the same error.

 

 

Thanks!

Ruggero_Piccoli
Employee
Employee

Hi,

So, there is something in the selection you are applying that generate an incompatible issue. I suggested to apply one-by-one so you should understand what is the selection that is causing the issue.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Ri_ta
Partner
Partner
Author

Hi,

The QS app has no filters applied  and I created a new filter for the NPrinting report and applied it. I got the same error. If I remove the report filter, it works.

Lech_Miszkiewicz

Hi,

It looks like your Qlik Sense application has "Always One selected value" property set on one of the fields. This is officialy not supported.

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.