Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

microwin88x
Contributor II

Filter Report by Employee with NPrinting

Hello,

I have a report where I was previously using PDF Distributor to reduce by field EMPLOYEE_ID and it sent to the MAIL_ADDRESS field.

Now we migrated to NPrinting and I'm using NPrinting Designer to import the report but I've been looking in Community how to filter every EMPLOYEE_ID and send the report (PDF) to the associated MAIL_ADDRESS, but I found that I need to create a table in the application

So I created the following table with the FILTER column:

EMPLOYEE_IDEMAIL_ADDRESSGROUPFILTER
1employee1@test.comGENERALEMPLOYEE_ID = {1}
2employee2@test.comGENERALEMPLOYEE_ID = {2}
3employee3@test.comGENERALEMPLOYEE_ID = {3}

Is this OK so far? Because when I run the task it doesn't filter by EMPLOYEE_ID, it sends the FULL PDF to every EMPLOYEE_ID.

Do you know how to do that?

Thank you!!!

1 Solution

Accepted Solutions
geminihzh
Valued Contributor

Re: Filter Report by Employee with NPrinting

Hi, Micro,

The method it totally correct.

Can you pls check in the imported email address, are the filter correctly imported?

And just in case, which nprinting version do you use?

And are you sure your test reports for each EMPLOYEE_ID do have data?

Because by default, if the filter gets a result, then it will run the whole report

To avoid this, you need to add "<verify>" for all the filter, for your case, the value is:

EMPLOYEE_ID = {1}<verify>

Pls check the usage of the filter when creating them in a QV dash:

Filter Syntax, Parameters, and Options for Importing Recipients

1 Reply
geminihzh
Valued Contributor

Re: Filter Report by Employee with NPrinting

Hi, Micro,

The method it totally correct.

Can you pls check in the imported email address, are the filter correctly imported?

And just in case, which nprinting version do you use?

And are you sure your test reports for each EMPLOYEE_ID do have data?

Because by default, if the filter gets a result, then it will run the whole report

To avoid this, you need to add "<verify>" for all the filter, for your case, the value is:

EMPLOYEE_ID = {1}<verify>

Pls check the usage of the filter when creating them in a QV dash:

Filter Syntax, Parameters, and Options for Importing Recipients

Community Browser