Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Read about the latest Qlik Community enhancements on the Community News blog!
cancel
Showing results for 
Search instead for 
Did you mean: 
PoojaPrasad
Creator II
Creator II

How to enable padding on first column of table in pixel perfect report

Hello Experts,

I am trying to enable padding on first column of the table in pixel perfect report. I have specified "Use Padding" as Yes and then trying to give a number on left in Padding section as shown in below image. But every time I specify any number on Padding, the "Use Padding" option automatically become No. Do we have any document that explains how to add a space for first column values so that it does not hit the border on left.PaddingIssue.PNG

 

Labels (2)
1 Solution

Accepted Solutions
Lech_Miszkiewicz

Well - you must be doing something wrong or something is corrupted.

The padding settings are straight forward and they are those which i have highlighted in my screenshots below..with the outputs as well..

padding added

1.PNG

2.PNG

 

no padding

3.PNG

4.PNG

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.

View solution in original post

5 Replies
Lech_Miszkiewicz

If you want to specify padding in padding field just do it and test it (dont worry about switching Padding to Yes in Style Priority section.

From my observations "priority" may be in use when you have conditional styles placed on top of the original ones...

details about PixelPerfect library can be found on devexpress support page:

https://www.devexpress.com/

 

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
PoojaPrasad
Creator II
Creator II
Author

Hello,

I did try adding numbers in padding field. But it automatically changes to 0 again and I dont see padding working on the report. 

Also checked the below link but could not find a proper solution to the issue of adding padding on table defined in levels in pixel perfect report.

 

Lech_Miszkiewicz

Well - you must be doing something wrong or something is corrupted.

The padding settings are straight forward and they are those which i have highlighted in my screenshots below..with the outputs as well..

padding added

1.PNG

2.PNG

 

no padding

3.PNG

4.PNG

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.

View solution in original post

Lech_Miszkiewicz

or maybe this is what you are doing wrong...each column has different settings on each level.. if you want to add padding to first column you need to select it separately (click on  placeholder which will produce this column...)

note how on my screenshots i have clicked on cell where [Dim1] is placed... If I would have group header with headers I would have to apply this settings separately  on it as well.,, In other words setting applies to a "cell" which then gets populated.

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
PoojaPrasad
Creator II
Creator II
Author

Hello @Lech_Miszkiewicz ,

Thank you for the elaborate explanation. I did try 50 and it worked. Earlier I was trying 1 or 10 and both did not work. I still cannot give 1 or 10 as padding numbers but 5, 11 and 50 do work.  Have you tried giving 1 or 10 as padding value?

Anyway padding with value 11 is working for me. 🙂

Thank you once again.