Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
WE ARE LISTENING! New Navigation for Qlik Community, Sept. 26: TELL ME MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
LDR
Contributor III
Contributor III

How to set decimal separator when your report is a QlikEntity report and the export format is TAB???

Hello everybody,

 

First at all thanks in advance for your help 😉

 

My question is how can I change the decimal separator if the type of report is QlikEntity and I want to export some Qlik Sense object in TAB format.

Let me give you some examples:

  • In my Qlik Sense app the configuration is such as:

LDR_0-1643125594432.png

The values I want to export:

LDR_1-1643125656583.png

Everything looks fine.

  • On the other hand, when I export this data in TAB format  I obtain the result below:

LDR_2-1643125742786.png

My decimal separator was replaced by point.

 

I was reading other posts and it seems that the reason of this behavior is because OS regional settings. Do you know if is that? 

Do you have any clue?

Regards

 

Labels (2)
1 Solution

Accepted Solutions
Ruggero_Piccoli
Support
Support

Hi,

Change the regional settings of all the computers where you are running Qlik NPrinting Engine Windows services or force the field as text() in the original Qlik Sense table.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

4 Replies
Ruggero_Piccoli
Support
Support

Hi,

Change the regional settings of all the computers where you are running Qlik NPrinting Engine Windows services or force the field as text() in the original Qlik Sense table.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
LDR
Contributor III
Contributor III
Author

Thanks Ruggero, finally I applied the text() workaround and as soon as it'll be able I will check regional settings. 

Best regards

Ruggero_Piccoli
Support
Support

Hi,

Please note that the Text() function will influence only the table where you apply it instead changing the regional settings of all the Qlik NPrinting Engines computers will influence all generated reports. So you have to select based on your goals.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
LDR
Contributor III
Contributor III
Author

That's the point. Using Text() is a neutral change and it just affects my report and on the other hand, if I change regional settings, it can affect to the other reports I have.

Thanks for your advice

Best Regards