Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Kev4IN
Contributor II
Contributor II

Issue with Database Nprinting could not be queried, causing NpgsqlConnector to raise NpqsqlTimeOut

I am experiencing technical errors that have been collected in the Log files when daily backup of Nprinting is performed. The version of the Nprinting is May 2021. Can anyone look at the contents of the log file as shown in the pictures (Nprinting_error_pages 1 and 2) attached and suggests some solutions for me to overcome the issues, allowing daily backup to be performed again? The errors may be due to socket or Npgsql connection issue that I am not familiar with.

Labels (2)
3 Replies
Lech_Miszkiewicz

What are the steps you do during backup?

Do you stop services as required and use steps and commands from https://help.qlik.com to perform it?

do you have enough space on Hardrive to perform backup including reports stored in newsstand and audit logs?

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Kev4IN
Contributor II
Contributor II
Author

Hi @Lech_Miszkiewicz , thanks for your questions. Can I know whether you have seen the log's contents in the pictures that I have attached.

I will provide information about your questions.

(1)  I have allowed Stopping of the services for Audit, Engine, scheduler, Web engine, License, messaging, and repo. They were completely stopped before the backup was started. 

(2) The space to store those reports and logs is enough. Right now, my space have 1 Tb left. We have another server to host a database to store these old reports and logs have been produced after a month. 

This issue arises suddenly and I am not sure what happens now because it has been working fine for the previous three months. 

Please advise me further. Thank you. 

Lech_Miszkiewicz

Hi @Kev4IN 

Well - first of all Qlik NPrinting RepoService must be running to create a backup. If you stop it as you said above then that is your issue.

 

I tried to read those errors from your screenshot but it is hard given that they are blurry, taken with the angle and not captured in full.

Can we take maybe one step back and talk about issues

- What is your main issue?

1. Is it that when RDPing to NPrinting server you are unable to perform steps to run backup like described in here: https://help.qlik.com/en-US/nprinting/May2021/Content/NPrinting/DeployingQVNprinting/Backing-up-Qlik... ?

Running such command should provide you with view like this one: 

Lech_Miszkiewicz_0-1640923335031.png

Are you able to do that?

Lech_Miszkiewicz_1-1640923617047.png

If you are able to run it manually do you get a backup file created or not?

2. You are showing us some logs. I tried to identify them by looking at what they contain but It is not visible enough and really hard to read.

  • Where did you get them from?
  • What are the names of the log files?
  • Are you referring to logs from C:\ProgramData\NPrinting\Logs location?
    • if yes - which one?
    • if no - what are the logs you are talking about?

3. I guess you are running this process as automated task? Correct? If yes - then we would need to look at the process you setup and try to understand how you do it? If you are using correct permissions? If it is simply batch file or maybe powershell script etc..

 

Are you able to attach logs here so we could look at them? If there is any sensible data like server names or similar you may just mass-update it with some random names.

Other questions:

  • is there any other service running on the server where NPrinting is installed?

 

 

 

 

 

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.