Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
See why Qlik was recognized for the seventh year in a row – and discover how we can help you tackle your data integration challenges. Get the report
cancel
Showing results for 
Search instead for 
Did you mean: 
nerakegl
Partner - Contributor II
Partner - Contributor II

Missing rows in table (NPrinting Februry 2019)

Hi all, 

I made a table in QS, table has header and one row. 

I made a pdf report, sometimes when I generate report the row with data is missing, I just have a header. I dont know why, I have enough space on my page.

Version of Nprinting is February 2019.

Did you have that kind of problem? Is it a bug maybe?

Thank you in advance.

Labels (2)
3 Replies
Lech_Miszkiewicz

Hi,

maybe your QS table does not produce data for given selection/filter/or whatever else you have in your "one row". Give us some more information. 

Please add some attachments, screenshots of your expression, give use some context if you use filters, section access, conditions, how is your table built, do you suppress 0 values, do you suppress null values etc.

What template are you using in NPrinting? Can you screenshot how your template is built? Are you using any calculated dimensions?

There is so many different things you have to take into account that without some basic description it is hard to help you.

cheers

Lech

 

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
nerakegl
Partner - Contributor II
Partner - Contributor II
Author

Hey, thank you for answer.  Here is more details.

I have a table like this Untitled.png

These are all the measures in this straight table. 

I insert it as picture in word template report. Sometimes this happens and I cannot control it. 

asdsad.png

I dont have section access in my app. This is the screenshot of template.

lll.png

 

Lech_Miszkiewicz

Well, usually we investigate the source of the problem not a result. So i was hoping actually to see screenshots of expressions (and not the numbers which are results of expression being calculated) as it does not give us important information of why sometimes you may not have numbers in it.

now:we are still waiting for other answers i asked previously:

  • do you use filters?
  • maybe you don't use filters in report, but you use them in task
  • what do you see in " task execution" section of admin console after you receive empty tables (no errors? no warnings?)
  • maybe you have some recipient filters for this connection?
  • do you use conditions?
  • do you use conditional hide/show on columns in tables?
  • do you suppress 0 values?
  • do you suppress "null" values?
  • you have not screenshot us a template - it is important to screenshot everything (entities of the left hand side of template editor so we can see how those are used within template
  • are you using any calculated dimensions? 
  • you have shown us 1 table but in screenshot of template you actually have 3 images? Are all objects not being populated, are all of them blank sometimes? This would indicate that you filter data out somewhere

I believe you understand where i am coming from with all those questions and you will be able to provide detailed answers so we can actually help you!

cheers

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.