Qlik Community

Ask a Question

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Welcome to our newly redesigned Qlik Community! Read our blog to learn about all the new updates: READ BLOG and REPORTED ISSUES
cancel
Showing results for 
Search instead for 
Did you mean: 
Creator
Creator

NPrinting 17 Entity Tags Error In PowerPoint

Hi,

I keep getting an error when I try to amend a PowerPoint report in NPrinting 17.

An error occured while elaborating the entity tags.

Please check if the entities are properly placed inside their level tags.


I have set up a page object to loop through a field to create slides. It all works fine until I want to amend a report to insert a slide ahead of the slide with the page tag. It seems that NPrinting still thinks the tag should be on the slide number it was on before and there is no way to fix this. You can never move the slide. Once you get the error you lose any work since you last saved the report.


Even if you have the page tag referring to slides 12-15 and you change that reference to 13-16 after inserting a slide, sooner or later you will get that error again. I have tried deleting the page item and the slide with the tag but the error keeps coming back and then the report is permanently corrupted.


Any ideas?

1 Solution

Accepted Solutions
Employee
Employee

Hi,

Check also that the Designer version is the same as the server.

You could also check the logs.

If you still have the issue after the upgrade please open a support ticket so we will investigate if it is a bug.

Best Regards,

Ruggero

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT https://community.qlik.com/docs/DOC-14806. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

16 Replies
Employee
Employee

Hi,

I tried to reproduce your issue in my installation but I was not able. With my Qlik NPrinting everything is working fine and I'm able to add slides before and after the one with the Pages field. Also if I reorder the slides with Pages on many of them everything is working fine. I tried also by mixing Pages filed from Qlik Sense and QlikView on the same template and it is fine.

What version of Qlik NPrinting are you using? Could you upgrade to latest (June 2018) available and try again?

Best Regards,

Ruggero

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT https://community.qlik.com/docs/DOC-14806. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Creator
Creator

Hi Ruggero,

We are using the April 18 version. I will try to get it upgraded as it sounds like a bug which has been fixed, but that might not be a quick process to get approved.

I have just recreated my report from a version I exported without the paged slides. It runs from the Publish Task menu, but when I go into the Template Editor and preview it, I get the error. If I go into Template Editor and click Save and Close immediately, it is fine. If I change anything, such as a title box, I get the error so I cannot make further changes.

I will try to do the upgrade, but my best option now is to recreate the report from scratch, export without the Page items and keep that as a clean version, then add the Page items last.

Chris

Employee
Employee

Hi,

Check also that the Designer version is the same as the server.

You could also check the logs.

If you still have the issue after the upgrade please open a support ticket so we will investigate if it is a bug.

Best Regards,

Ruggero

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT https://community.qlik.com/docs/DOC-14806. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

Creator
Creator

The server is June 18, but the Designer is April 18. I should be able to install the new designer on my machine fairly soon. I will let you know.

Creator
Creator

I have installed the new version but I still get the same error. This might be because it was created under the old version. I will let you know if it happens again with any new reports I create.

Thanks for your help.

Chris

Employee
Employee

Ok.

Try to move some slides, save, move them back and see if you still have the issue.

It is possible that the wring version of the Designer miss some info when saving the template.

Best Regards,

Ruggero

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT https://community.qlik.com/docs/DOC-14806. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Creator
Creator

I will mark your reply as correct as it was definitely an issue that needed fixing.

Chris

Master III
Master III

Hi,

Could you find anything more on this? One of our report is throwing same error while previewing. It works fine through task though.

kidbank3

Partner
Partner

Have you find the solution? I am getting same error. Not sure what to do next. I reinstalled the nPRinting server, engine and the designer, but it didn't help.

Thanks for any advise.

B