Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Not applicable

NPrinting 17 - Generating

Hi

I have installed NPrinting 17 Server on a fresh Windows 2012 VM, created an app, and now trying to create a connection. I have tried both a local QV app and a server-based app, and for both of these the Connections show as "Generating", and never get to "Generated".

In the 'nprinting_engine.log' file I can see (ip address removed):

2016-03-06 11:49:00,303 [32] WARN Qlik.NPrinting.Engine.Consumer.BlockingContentResolver - Navigator stuck on connection f9eb5ae1-2d35-4857-acf9-54f487890511, forcing close of connection. STACK: Qlik.Reporting.Engine.Messages.Exceptions.NavigatorStuckException: Navigator navigator=qlikview;documentpath="qvp://@00.00.00.00/Sales Compass.qvw" is stuck and can't be used anymore to resolve requests ---> System.Runtime.InteropServices.COMException: Error HRESULT E_FAIL has been returned from a call to a COM component.

Can anyone suggest any mechanism of identifying the problem?

Thanks

Al.

32 Replies
sifatnabil
Contributor III

Re: NPrinting 17 - Generating

Same thing happened to me. But I tried creating a completely new qvw and saved it locally with a single chart, and that generated fine. Can't figure out what the issue is. There is definitely a desktop license on the machine too.

sifatnabil
Contributor III

Re: NPrinting 17 - Generating

I just checked again and it looks like there were way too many objects/sheets on my qvw. This probably caused a lengthened generating time. After reducing sheets and unnecessary objects, the generating worked.

Not applicable

Re: NPrinting 17 - Generating

Hi all,

When i'm creating a connection to a QVW my cache status is stuck on 'Generating'.

I tried to do the suggestion above and it doesn't work.

have any idea?

thanks a lot,

gal

Not applicable

Re: NPrinting 17 - Generating

QV Server and Desktop must be the same version (even SR).

Have you applied a license for the NPrinting Service account user?

and then... apparently there is a bug in QV11 when there are tables in containers. Fixed in QV12.

nwatson-qit
New Contributor

Re: NPrinting 17 - Generating

QV Server and Desktop must be the same version (even SR).

Is this definitely true?

Not applicable

Re: NPrinting 17 - Generating

It is in system requirements so it comes from Qlik. Can it work without... I suspect it probably could if there is no 'handshake' between the local and server installation, and I doubt there is. Connecting to a doc on the Server seems not to require QlikView locally, and certainly vice versa.

Luminary
Luminary

Re: NPrinting 17 - Generating

I had this same problem.  I did the following to fix the problem.

1. Stop NPrinting services

2. Delete the NPrinting folder in c:\programdata

3. Start NPrinting services

This might be a little extreme and after looking the the subfolders in the programdata folder, you might be able to get away with just deleting the "ondemand" folder or the cache files in the apps folder.

Of course, when I say delete, I'm implying that you back up everything just in case you delete a template or a report you end up needing.

Best, Karl

erjohnso
Contributor

Re: NPrinting 17 - Generating

I had this issue and it was being caused by using the same server id/account to run both QlikView and Nprinting services. Qoncierge also advised the following steps to restart services (which worked for me):

Steps:
1. Delete any of the Cash Daily connections
2. Stop the following services:
-QlikView NPrinting server
-Qlikview NPrinting Web Engine
-Qlikview NPrinting Engine
-Qlikview NPrinting Repo Service
-Rabitt MQ

3. Start the above services again starting with rabbit mq and move up the list one at a time.
4. Create a brand new connection and new connection name.
5. Generate the connection.

ernestogaona21
New Contributor II

Re: NPrinting 17 - Generating

Hi Mr. Eric,

Help me please!,

When I tried to create a connect  with type Server, the caché status.. display an error.

Please, check my data information for create a connection.

create conex.PNG

Caché Status Error.PNG

Regards,

Community Browser