Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

kdmarkee
Contributor III

NPrinting 17 On Demand - no access to resources

I'm hoping someone can offer some guidance on what might be going on.  I have On Demand working on our intranet Access Point but cannot get it to work for our extranet Access Point, and I get 3 different results based on the browser I use.

1) IE - a cert alert that I click Yes to, and then a second error 403 user has no rights to access the resource

ie error 1.PNG ie error 2.PNG

2) Chrome - Create one in NPrinting or make sure you have access rights

chrome error.PNG

3) Firefox - No connection with NPrinting server. Please check your network settings or contact the administrator.

firefox error.PNG

Thanks.

1 Solution

Accepted Solutions
kdmarkee
Contributor III

Re: NPrinting 17 On Demand - no access to resources

Qlik Support told us to try publishing our QV docs to the root folder and that did the trick.

3 Replies
kdmarkee
Contributor III

Re: NPrinting 17 On Demand - no access to resources

Qlik Support told us to try publishing our QV docs to the root folder and that did the trick.

kdmarkee
Contributor III

Re: NPrinting 17 On Demand - no access to resources

For anyone who has read this or is trying it for their scenario, note that I am now struggling to get my same report to function using the revised path in my NP web console connection.  It works using the Preview button in NP but errors from the On Demand button with the non-helpful and generic "Wrong content node response type" error from the log.  So now I am trying to see if I can figure out what is causing this. Knowing there is a bug with NP 17 that forces us to us the root folder for publishing our docs to get On Demand to appear, I can't help but wonder if there are other bugs related to report generation from On Demand as well.

kdmarkee
Contributor III

Re: NPrinting 17 On Demand - no access to resources

I opened a case with Qlik, they said to upgrade to 17.5 and still no luck with either using mounted or root folder locations.  Hoping to hear back from Qlik rep in the very near future and can update this once I know more.

Community Browser