Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

kdmarkee
Contributor III

NPrinting 17 - is Designer required

Quick question for anyone familiar with NP...if you upgrade your NP Server and Engine, do you also have to update your Designer ON THE SAME NP SERVER?  I updated my local Designer install as that is where I develop reports but is it a requirement that the Designer version on the NP server match the version of the NP Server and NP Engine?  Thanks.

Tags (1)
1 Solution

Accepted Solutions
Employee
Employee

Re: NPrinting 17 - is Designer required

Yes,

The NPrinting Designer, NP Server and NP Engine should always be the same version.

Error will be the results if any or all of the components are installed as different versions.

One reason specifically is that .NET framework needs to be consistent and need to match the server and engine etc.

Planning your deployment ‒ Qlik NPrinting Sept. 2017

.NET 4.6.2 requirement for all NP components

Planning your deployment ‒ Qlik NPrinting  June 2017

.NET 4.5.2 requirement for all NP components

Also aside from .NET, the back end schemas for each NP component must match ie: same version or errors in report development or automated deliver will ensue.

This community user does not receive direct private messages
4 Replies
Employee
Employee

Re: NPrinting 17 - is Designer required

Yes,

The NPrinting Designer, NP Server and NP Engine should always be the same version.

Error will be the results if any or all of the components are installed as different versions.

One reason specifically is that .NET framework needs to be consistent and need to match the server and engine etc.

Planning your deployment ‒ Qlik NPrinting Sept. 2017

.NET 4.6.2 requirement for all NP components

Planning your deployment ‒ Qlik NPrinting  June 2017

.NET 4.5.2 requirement for all NP components

Also aside from .NET, the back end schemas for each NP component must match ie: same version or errors in report development or automated deliver will ensue.

This community user does not receive direct private messages
kdmarkee
Contributor III

Re: NPrinting 17 - is Designer required

OK.  If one is not on the same version for all 3 components, could it cause this error:  "windows could not start the qlik nprinting schedule service on local computer. error 1067."  I'm getting this now as a result of enabling DEBUG mode in the scheduler config file and trying to restart the scheduler service.  Thoughts?  Thanks.

Employee
Employee

Re: NPrinting 17 - is Designer required

The NPrinting Designer, NP Server and NP Engine MUST always be the same version. :-)



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
kdmarkee
Contributor III

Re: NPrinting 17 - is Designer required

I needed to specifically say that Designer is not being used on my NP machine, and with that said, I have confirmed that if you are not using Designer on the NP machine then no, the version doesn't matter.  However, if you are not using Designer on your NP machine, then it is probably best not to have it there so you are not tempted to use it, OR, even if not using it keep it updated for consistency.

Community Browser