Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

oggieben
New Contributor

NPrinting 17 not returning correct data

We have an NPrinting 17.2.1.0 Excel report which used to be fine in v16. Since the migration to v17, we have been experiencing the following problems:

Most days now, the data being returned is corrupted. By this I mean that data is partially repeated on the same tab.

We have had instances of yesterday's data being returned.

Oddly enough, when it runs on Monday morning it is correct.

I have seen problems being reported to do with the cache and I just wondered if this could also be our issue.

Thanks

Chris

Tags (1)
8 Replies
Employee
Employee

Re: NPrinting 17 not returning correct data

Hi Chris,

What kind of connection are you using (Local, Server or Cluster)?

How are you reloading the document used in the connection?

When does the reload take place and when does it finish?

When is the report scheduled to run?

How long does the reload take?

When was the reload run (and when did it finish) before Monday's report was generated?

If no obvious possible cause pops up when answering the above I suggest you open a case with Support.

HTH - Daniel.

oggieben
New Contributor

Re: NPrinting 17 not returning correct data

Thanks Daniel,

We are using a Server connection to the QlikView app which is being reloaded using the QMC. The reload occurs around 07:40 every morning. It takes approx. 18 secs to run.

The NP task was set to run at 09:30, but we changed it last week to run at 10:00, just in case there were clashes that we were not seeing.

I have looked at the logs (a task in itself) and I cannot see anything going wrong.

Looks like a support call then,

Regards

Chris

Employee
Employee

Re: NPrinting 17 not returning correct data

Chris - see the following for a workaround that should ensure that your connection has refreshed data.

prisma_d_horvat
Contributor II

Re: NPrinting 17 not returning correct data

Alternatively, it should work with version 17.3. There were some bug fixes that help here.

oggieben
New Contributor

Re: NPrinting 17 not returning correct data

Thanks Stephen,

My apologies, we are using the app itself as the source not the access point instance.

oggieben
New Contributor

Re: NPrinting 17 not returning correct data

Hi Danijel,

This is the option we are going to take. I will update the post once we have the results.

Employee
Employee

Re: NPrinting 17 not returning correct data

Hi Chris,

If you are using a QVW that is being reloaded by the QMC you must use a Server type connection (qvp) in NPrinting. If you instead connect as a local connection you could get stale or mixed stale & fresh data if you do not reload the metadata (version 17.3) or restart the NPrinting services (all versions). I have seen this before.

HTH - Daniel.

oggieben
New Contributor

Re: NPrinting 17 not returning correct data

Hi,

17.3 is indeed the answer.

Thanks for the help with this issue,

Community Browser