Qlik Community

Ask a Question

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

cancel
Showing results for 
Search instead for 
Did you mean: 
arniewolff
Contributor III
Contributor III

NPrinting 17 - template not found

We upgraded to NPrinting 17 by first exporting the projects in version 16 and then upgrading. After creating the app, connection and report, I'm trying to import the templates. But I only see 2 of the 3 templates that are in the project. What did I do wrong?

4 Replies
sbbazaldua0826
Contributor
Contributor

Does the missing template by chance include anything related to cell by cell?

arniewolff
Contributor III
Contributor III
Author

Yes, if I understand your question correctly. It is a complicated PixelPerfect template that has images, individual fields from charts, and lists of records.

sbbazaldua0826
Contributor
Contributor

Open up the zip file you created when exporting the templates out of NP 16. Double click on the folder "templates". What size (KB/MB) is the missing template you are not seeing in NP 17? If the missing template is larger than the others then you may have some items within the template that are not being used that is causing this issue.


When you open the Powerpoint template editor in NP 16 do you have anything listed under "Cells" on the left hand side of the template editor screen? If not then my solution may not help. I had this same issue where individual fields listed under "Cells" in NP 16  that were not being used in the generation of the report caused the template to not be visible in NP 17. Once I removed these fields and re-saved the template, then re-exported the nsq the template was visible when trying to re-add it in NP17. 

arniewolff
Contributor III
Contributor III
Author

The template in the original folder is a bit larger than the others: 271 KB is missing, I see the 2 that are 192 KB and 146 KB. It looks like another template that is 132 KB is also missing. But once it's in the zip folder, the templates all have scrambled names. There are 4 of them in the zip folder.

Since I'm using PixelPerfect and not Powerpoint, I don't think the "Cells" issue applies here.