Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

cancel
Showing results for 
Search instead for 
Did you mean: 
ccastrillo
Contributor II
Contributor II

NPrinting Authentication mode

Hi all,

by  mistake, I have changed the authentication mode to windows user instead Nprinting local in Nprinting web console. Obviously, after that, when I try to access to Nprinting web console, only Windows loggin option is available, but I cannot access with any of the windows users (rights checked). Is there any way to change (Enable) the Nprinting authentication outside Nprinting web console?

Many thanks in advance!

Nprinting Auth settings.png

Labels (1)
3 Solutions

Accepted Solutions
Ruggero_Piccoli
Support
Support

Hi,

Also if you had enabled the Windows authentication you can insert the email and password of the user and login. 

Login Form.png

The Windows domain user is associated with a Qlik NPrinting user so the system know the match.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

ccastrillo
Contributor II
Contributor II
Author

Hi Ruggero,

thanks for your answer. Unfortunately, the login page only shows windows option. Login with Nprinting credentials option doesn't appear. And I guess it is because there's no Windows domain user associated with any Nprinitng user. Before the change, I usually loged with the Nprinting user defined during installation.

Hope this clarifies. Please let me know any iddea you may have to solve this issue.

Many thanks in advance

César

View solution in original post

Ruggero_Piccoli
Support
Support

To inform all readers that the issue was solved via support ticket.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

7 Replies
Ruggero_Piccoli
Support
Support

Hi,

Also if you had enabled the Windows authentication you can insert the email and password of the user and login. 

Login Form.png

The Windows domain user is associated with a Qlik NPrinting user so the system know the match.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
ccastrillo
Contributor II
Contributor II
Author

Hi Ruggero,

thanks for your answer. Unfortunately, the login page only shows windows option. Login with Nprinting credentials option doesn't appear. And I guess it is because there's no Windows domain user associated with any Nprinitng user. Before the change, I usually loged with the Nprinting user defined during installation.

Hope this clarifies. Please let me know any iddea you may have to solve this issue.

Many thanks in advance

César

Ruggero_Piccoli
Support
Support

To inform all readers that the issue was solved via support ticket.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
kss7374
Partner
Partner

Hello,

I faced the same problem, can you share how you managed to solve it?

Thank you,

BR,

Sergey

 

 

 

 

 

 

Lech_Miszkiewicz

Hi @kss7374 

As @Ruggero_Piccoli mentioned this was done via support as typically it will require adjustments to NPrinting repository db which may result in its damage. 

Long story short depending on particular situation it may require adding AD credentials to one of the accounts so windows authentication can be used, or changing values by updating "Setting" table in postgres by changing values for "name".web-auth-nprinting-enabled" to "true"...

Hence this is typically task for support and it is not recommended to mess with it unless you know what you are doing.

cheers 

 

 

 

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Ruggero_Piccoli
Support
Support

Hi, @kss7374 ,

You should be able to login by inserting username (email) and password instead of using Windows login. Otherwise please follow @Lech_Miszkiewicz 's suggestion and open a support ticket. Be sure to have an updated backup of your installation.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
kss7374
Partner
Partner

Hello guys !

Thank you very much for your help - the problem is solved (Postgres)

BR,

Sergey