Qlik Community

Ask a Question

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
QlikWorld starts MONDAY! last chance to register is now ! REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
janz2010
Contributor II
Contributor II

NPrinting Connection problem

Dear community,

I am currently haveing problems with my connections in NPrinting.

When I try to reload the meta data it's always failing, whilst my reports based on the connections are still performing fine. How is that possible?

Next strange thing is that if I run a verification of my connections (I only have 2) via the web based interface, NPrinting would return an error to me for both of them: The specified identity can't open the document. What does this mean?

For me now it's unclear why my reports for both of my connections are still running. Concerning the reload of the meta data only one of the two connections is failing.

If you'd like to I can upload the log file, but as far as I can tell it will only return the following message:

Connection navigator=qlikview;documentpath=qvp://qlikview/HELLMANN_FINANZEN_APP.qvw has reached ERROR status

Thanks for your help!

BR

Jan

4 Replies
Ruggero_Piccoli
Employee
Employee

Hi,

Be sure you are satisfying all the requirements listed in the page https://help.qlik.com/en-US/nprinting/June2018/Content/DeployingQVNprinting/NPrinting-with-QlikView....

The QlikView desktop instaled in the Qlik NPrinting Engine computers must have a valid license activated. Personal edition and leased licenses from the QlikView Server are not supported.

Login to the Qlik NPrinting Engine computer and run the QlikView desktop with the same domain user that runs the Qlik NPrinting Engine service. Then open the .qvw directly in the QlikView desktop. Everything have to work fine.

Check also the Qlik NPrinting Server logs.

Best Regards,

Ruggero

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT https://community.qlik.com/docs/DOC-14806. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
janz2010
Contributor II
Contributor II
Author

Dear all,

let me give you a short update to this Topic. I am still having Problems with one specified Connection in NPrinting.

Please see attached the relevant screenshot and an extract from the log file regarding the reload of the metadata.

Maybe someone can give me a hint what's going wrong here.

Thanks a lot!

BR

Jan

Ruggero_Piccoli
Employee
Employee

Hi,

logs say that you have issue in the original QlikView document. For example "The columns calculation of conditional information failed for sheet object Document\CH403" so start by checking all the objects are generating errors in the original document.

Logs show that there are many different objects that generate the same error so you could have an issue common to all of them. I would to suggest to try to reload the data in the .qvw and check that all objects are correctly filled.

Best Regards,

Ruggero

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT https://community.qlik.com/docs/DOC-14806. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
pwagner
Partner
Partner

Hello Jan,

I have/had the same issue. 

My solution is/was, that all NPrinting users have got 'read' access to the QVW folder on the QlikView Server. After that the connection to the QVW was possible.

 

Best regards, Patrick