Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Coming Aug. 9: New Simplified Authoring for Qlik Sense SaaS – For Details, CLICK HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
gavin_kite
Partner - Contributor III
Partner - Contributor III

NPrinting Engine Failed to open document

Hi

 

I'm after some pointers on what to try to get NPrinting a little more stable. Today I have had 4 out of 37 jobs fail all with the same failure reason 'NPrinting Engine Failed to open document'

Current Set up

  • NPrinting - November 2018
  • Qlikview - November 2018

Things I've tried/noted

  • Apps do not have section access.
  • Apps have not been moved or changed names.
  • When NPrinting reports are re-ran after failures, they usually run fine.
  • Its not always the same tasks that fail. Sometimes tasks fail,sometimes they dont.
  • Sometimes its the cache refreshes that fail, sometimes end user reports.
  • Able to open Qlikview desktop on NPrinting server and open an app via 'open in server'
  • Have scheduled windows task to restart NPrinting services weekly.
  • Have scheduled windows task to restart NPrinting server weekly.
  • Have tried moving NPrinting reports away from times when QV docs are being reloaded.
  • Have created triggers on all connections to refresh connection/meta data.

Has anyone else had this issue? What am I missing?

Thanks

 

 

Labels (4)
4 Solutions

Accepted Solutions
Frank_S
Support
Support

Check to make sure that you have no unsupported items in your QVW. 

This is typically caused when an 'On Open' trigger is used in the QWV. This is just one of the unsupported items you need to check for and address but there are several you may need to address as per the article in the link below:

Nprinting: Unsupported QlikView Document items, System Configurations and other limitations

https://qliksupport.force.com/articles/000026081

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

Frank_S
Support
Support

Check the points in this checklist via the following link:

https://qliksupport.force.com/articles/000028729

You've covered some of these already.

If this doesn't work, then I recommend starting separate Qlik Support cases to investigate each issue you are experiencing.

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

Frank_S
Support
Support

Sure you can try this:

1. Abort all running NPrinting Executions via the 'Executions' link under Admin>Execution in the NP web console. Note that the default is to show only the first 10 executions. Click the 100 link at the bottom of the page to find all running task executions and abort them all

2. Restart your NPrinting and QV servers outside of Production hours.

3. Try again.

It's possible at this point that your system or systems may be locked up with Windows memory leaks and open/running executions.

Also try with:

- local NP connection c:\nprinting\qvws\myqvw.qvw

- QVP connection ie: qvp:\\myqlikserver\myqvw.qvw

Keep in mind that with QVP connections that the NP service account MUST be above to view it and open it. To test this, open the QV desktop on the NP server and do 'File>Open in Server' and navigate to the QVW on the QV server. If you cannot find it this way, then the NP service account does not have permission to open it. (do not try to use an 'alternate identity' to connect to the QVW. This too is also mentioned as unsupported in the documenation.

Finally make sure the NP service account is a member of the QV administrators group on the NP server.

So if none of this works then you will need to submit a case with Qlik Support or your Support Partner.

Publish all QWVs that the NP service account needs to see to the NP service domain user account.

 

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

Frank_S
Support
Support

@boopeshj 

It's possible that you have a performance problem, not enough resources, possible conflicting QV reload tasks running concurrently when NPrinting Publish tasks run, your version of NPrinting ideally should be Nov. 2019 to leverage performance enhancements and bug fixes.

Check this finetuning guide for performance sizing suggestions as well. https://support.qlik.com/articles/000034936

Occasional instances that you are referencing could be due to these points. Nov. 2019 has specific performance enhancements that may help your situation. See attached release notes.

 

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

11 Replies
Frank_S
Support
Support

Check to make sure that you have no unsupported items in your QVW. 

This is typically caused when an 'On Open' trigger is used in the QWV. This is just one of the unsupported items you need to check for and address but there are several you may need to address as per the article in the link below:

Nprinting: Unsupported QlikView Document items, System Configurations and other limitations

https://qliksupport.force.com/articles/000026081

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
gavin_kite
Partner - Contributor III
Partner - Contributor III
Author

Hi

Thanks for your reply..I wasn't aware that all of those objects weren't supported so will review as I'm sure this will be causing some of my problems. However, I've had a problem with a cache refresh on the  Rejects app this morning . Its a really simple QVW. No triggers, input boxes,no third party objects but as you can see from the task executions, its been really problematic, but then all of a sudden decided to start running  again.

All of the failures are reporting 'Cache generation failed: NPrinting Engine failed to open document. Check logs for details'

Any further suggestions?

Thanks

Gavin

 

Frank_S
Support
Support

Check the points in this checklist via the following link:

https://qliksupport.force.com/articles/000028729

You've covered some of these already.

If this doesn't work, then I recommend starting separate Qlik Support cases to investigate each issue you are experiencing.

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
Frank_S
Support
Support

Sure you can try this:

1. Abort all running NPrinting Executions via the 'Executions' link under Admin>Execution in the NP web console. Note that the default is to show only the first 10 executions. Click the 100 link at the bottom of the page to find all running task executions and abort them all

2. Restart your NPrinting and QV servers outside of Production hours.

3. Try again.

It's possible at this point that your system or systems may be locked up with Windows memory leaks and open/running executions.

Also try with:

- local NP connection c:\nprinting\qvws\myqvw.qvw

- QVP connection ie: qvp:\\myqlikserver\myqvw.qvw

Keep in mind that with QVP connections that the NP service account MUST be above to view it and open it. To test this, open the QV desktop on the NP server and do 'File>Open in Server' and navigate to the QVW on the QV server. If you cannot find it this way, then the NP service account does not have permission to open it. (do not try to use an 'alternate identity' to connect to the QVW. This too is also mentioned as unsupported in the documenation.

Finally make sure the NP service account is a member of the QV administrators group on the NP server.

So if none of this works then you will need to submit a case with Qlik Support or your Support Partner.

Publish all QWVs that the NP service account needs to see to the NP service domain user account.

 

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
boopeshj
Partner - Creator II
Partner - Creator II

Is having a trigger OnOpen is a problem with the latest Qlikview Feb 2019 version as well ?

Is it possible that OnOpen trigger fails NPrinting engine to open document intermittently?  

Ruggero_Piccoli
Support
Support

Hi,

Triggers and Macros in QlikView documents are not supported. You have to remove them or create a copy of the .QVW only for reporting. 

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
boopeshj
Partner - Creator II
Partner - Creator II

Thank you .

andrei_delta
Partner - Creator III
Partner - Creator III

Hi,

You can also check the server logs. You'll get a better idea of your current problem.

Also, you need to be sure is not a problem of performance. Maybe your reports are too demanding.

boopeshj
Partner - Creator II
Partner - Creator II

@Frank_S  But in my case, I notice this happens occasionally. I could understand if that is the case 100% of the time.  Any comments ?