Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
boonhaw_tan
Contributor III
Contributor III

NPrinting Import Task from LDAP/Excel Failed

Hi All,

I have NPrinting import task from Ldap is failed due to error below:-

20220213095634 Error Importing USER with name 'XXXXX' : could not initialize a collection: [Qlik.NPrinting.Repo.Model.Recipient.Roles#871fdebe-c245-4e3c-a8fb-d8c4f1a1bacd][SQL: SELECT roles0_.recipient_id as recipient1_48_1_, roles0_.role_id as role2_48_1_, role1_.Id as id1_59_0_, role1_.Version as version2_59_0_, role1_.name as name3_59_0_, role1_.description as description4_59_0_, role1_.enabled as enabled5_59_0_, role1_.has_all_actions as has6_59_0_, role1_.has_all_apps as has7_59_0_, role1_.is_system_role as is8_59_0_ FROM role_recipient roles0_ left outer join role role1_ on roles0_.role_id=role1_.Id WHERE roles0_.recipient_id=?]
20220213095634 Error could not initialize a collection: [Qlik.NPrinting.Repo.Model.Recipient.Roles#871fdebe-c245-4e3c-a8fb-d8c4f1a1bacd][SQL: SELECT roles0_.recipient_id as recipient1_48_1_, roles0_.role_id as role2_48_1_, role1_.Id as id1_59_0_, role1_.Version as version2_59_0_, role1_.name as name3_59_0_, role1_.description as description4_59_0_, role1_.enabled as enabled5_59_0_, role1_.has_all_actions as has6_59_0_, role1_.has_all_apps as has7_59_0_, role1_.is_system_role as is8_59_0_ FROM role_recipient roles0_ left outer join role role1_ on roles0_.role_id=role1_.Id WHERE roles0_.recipient_id=?]

I found PostgreSQL error below captured in Window Event.

2022-02-13 08:15:41.276 UTC [6800] FATAL: terminating connection due to administrator command
2022-02-13 08:15:41.275 UTC [5664] ERROR: lost connection to parallel worker

Would like to check if you encounter the same problem in NPrinting import task and how you resolve it?

Thanks,
Boon Haw

Labels (2)
5 Replies
Ruggero_Piccoli
Support
Support

Hi,

Please be sure that all Qlik NPrinting Windows services are running. Try also to connect to the LDAP server with a third party visualization tool. Run the import task with a user with Admin role.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
boonhaw_tan
Contributor III
Contributor III
Author

Thanks for reply, Ruggero

All the NPrinting services are up and running and the import task is run by user with Admin role. I tested the import task to import small amount of users < 1k and it work fine.  We sync around 20k of users from Ldap to NP, the same import task is working fine in QA environment. 

Regards,

Boon Haw

Frank_S
Support
Support

Hi @boonhaw_tan

 

Is there any chance that at any point, you have manually inserted/scripted NPrinting Security Roles into the NPrinting Database via the postgres sql query tool?

If yes, then you would need to remove any manually scripted NP security roles and replace them with roles created directly in the NPrinting Web Console 'before' attempting to use the LDAP import tool.

 

Also, please double-check with your LDAP administrator to ensure that the advanced LDAP entry properties are suitable for your specific environment.

 

Please look into these...if these are not the issue, I recommend that you submit a support request to investigate in greater detail.

 

Kind regards...

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
boonhaw_tan
Contributor III
Contributor III
Author

Thanks for response, Frank

We did not insert/update NP repository database via PostgreSQL tool as it not officially supported. Also checked with LDAP administrator the Entry attributes & Advanced  are look good as the same Entry attributes & Advanced work fine in QA. 

Support case 00021357 is logged for further investigate.

Regards,

Boon Haw

Ruggero_Piccoli
Support
Support

Hi,

Thanks for the support ticket. If possible, when solved, please share the solution with the community to be useful for other readers.

I just spoked with the colleague who is working on it.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.