Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Coming your way, the Qlik Data Revolution Virtual Summit. October 27-29. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Master III
Master III

NPrinting Sep 2018 - ERROR: All documents failed to generate:↓ A generic error occurred in GDI+

Hi,

A very strange error we have faced recently. Out of 200 Cycle field values, Power point reports are generated for the 199 values. For a single value we receive this error, power point report is failed to generate for this cycle field value. Strangely it throws error just for this one value and it repeated for the same value in next run.

Error displayed in task execution window and in the log is as below - 

Failed generation of report 6eb3e8e0-f7a3-4191-8e9c-3958d7f3c700 for user d69f5699-f80d-4a0b-ac58-1c05c38d5d02. ERROR: System.Exception: All documents failed to generate:↓ A generic error occurred in GDI+.

I tried different task when one report failed, it worked and generated report successfully for this specific cycle field value in one go. But I faced this again today for the same value and the same task which worked last time, didn't work for the first time.

I restarted services, reloaded meta data, but error kept on coming. I think in 4th or 5th retry it worked. Very strange! not able to link how it links to one of the specific cycle field value.

I googled on 'A generic error occurred in GDI+' and looks like this error troubled many in image specific issues. I couldn't find anything related to NPrinting though. It appears it might have link with image file locked when re-opened again internally but not sure how it links to our case.

Please let me know in case anyone faced something like this before.

Thanks,

DJ

 

 

 

 

Labels (2)
1 Solution

Accepted Solutions
Highlighted
Master III
Master III

Hi,

Looks like I found the specific chart object causing this error, deleting object from images panel   adding the chart object back to images and dragging back to the slide kind of fixing it but will watch for some more time.

This is the process I followed to detect the source of error.

1. Remove one slide at a time fro beginning.

2. Run the task with the cycle value as filter as this cycle value throws the error.

3. Check Task monitor, if you see the error again. Go to step 1 and delete next slide.

This way I found the chart which is the source of generation of this error. No recent change made in this chart so quite surprising. 

No idea why this is happening, whats the root cause? but it helped me to move ahead.

Fingers crossed, will watch it for some more time. Please share if you have any idea what could be the root cause behind this.

Thanks,

View solution in original post

10 Replies
Highlighted
Employee
Employee

Hi,

Do you have a filter on the same field you are using in the cycle?

Could you update to latest version (February 2019) and test with it?

Could you share the log files?

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Highlighted
Master III
Master III

Error has been seen with or without filter field same as cycle field. Strange thing is error is thrown for only one cycle value and its been same value every time.

We don't have recent plan to move to Feb 2019 so testing with it won't be possible as of now. Also don't have spare env to make that happen just for testing.

I will log case in support and share ID with you asap.

Thanks,

Highlighted
Master III
Master III

Hi Ruggero,

The case # logged in Qlik support is 01583877.

Attached log files as well over there. Hope you have access to the cases.

 

Thanks for your help.

DJ

Highlighted
Support
Support

@Digvijay_Singh 

I've reviewed your support case and attached this community discussion to the case so that the technician that will be working with you ahd the information you provided here as well.

Please forward to the support case your NP server and QS server specifications and the work will continue there.

Send the following to the  case for both your NP server and QS server:

  • # of CPUs
  • Ram installed on each server
  • Disk space available on each server

Do not share any of your confidential business support and environment information here since this is a public forum.

Feel free to share the solution here, once reached.

Thank you.

We are just 'like' you & like to be liked when we provide a helpful answer and or when you press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
Highlighted
Employee
Employee

Hi,

If you think the solution of the support case will be useful for all the community member, please share it also there. 

Thanks.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Highlighted
Master III
Master III

Hi,

Looks like I found the specific chart object causing this error, deleting object from images panel   adding the chart object back to images and dragging back to the slide kind of fixing it but will watch for some more time.

This is the process I followed to detect the source of error.

1. Remove one slide at a time fro beginning.

2. Run the task with the cycle value as filter as this cycle value throws the error.

3. Check Task monitor, if you see the error again. Go to step 1 and delete next slide.

This way I found the chart which is the source of generation of this error. No recent change made in this chart so quite surprising. 

No idea why this is happening, whats the root cause? but it helped me to move ahead.

Fingers crossed, will watch it for some more time. Please share if you have any idea what could be the root cause behind this.

Thanks,

View solution in original post

Highlighted
Master III
Master III

Hi,

Things are working fine now after deleting the object and adding it again.

So closing this post.

Thanks,

DJ

Highlighted
Support
Support

If the object ID behind the image changed due to a change in the source data in the QVF, this would explain the problem.

Each object has an ID behind it (except for master items which cannot be used as they have no object ids).

If an object was removed from the QVF and replace with an Identical object, note that this would essentially be a 'new' object and this new object would have a new object ID behind it.

This is possibly what may have happened based on how you were able to resolve the issue.

We are just 'like' you & like to be liked when we provide a helpful answer and or when you press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
Highlighted
Master III
Master III

I think this doesn't apply in my case, as I mentioned before I had 200 cycle field values, out of which it worked fine for 199 cycle values, same chart object generated perfectly 199 times in 199 different power point reports in my destination folder. It just failed for just one cycle field value and it kept on failing for the same value in subsequent runs. So no object ID was changed, report was failing for a specific data value. This is not good, I am still not finding any reason how any error/warning can link to specific data value. (Cycle field value).

Thanks,

DJ