Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

NPrinting editing template doesn't work (npp. file)

Hello community,

actual situation:

Qlik NPrinting version 17.3.1.0

Qlik Engine version 17.3.1.0

Connection to app: connedted

Engine: connected

Report: activated

If i want to edit the report (edit template) on server/client, the system always want to choose an app for opening files (npp) without any results.

Can someone help?

Thanks in advance!

9 Replies
Lech_Miszkiewicz

You need to install NPrinting Designer on the box where you want to edit template as well as Microsoft Office !!!


I believe you are having Scheduler and Engine installed only - aren't you?

btw. NPrinting 17 is recomended to have NPrinting Designer opened from user laptops and this also require each user to have NPrinting Designer localy installed.

cheers Lech



cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Not applicable
Author

Hi lech_miszkiewicz‌,

unfortunately i've installed NPrinting Designer as well as MS Office both on Server and Client and it doesn't work.

Any other guesses?

ashwanin
Specialist
Specialist

Seems problem in template file,Check if this problem occur with another templates?

If you have same problem with other templates then try to reinstall the msoffice.

Not applicable
Author

The problem also occurs if I create an empty file and try to open (edit) it.

ashwanin
Specialist
Specialist

Check format of template and ms-office version installed on your system.

Lech_Miszkiewicz

The pop-up window usually is coming up when system does not know what is the default program to open file.

I am thinking - maybe we could help your system to allocate right program to open nprinting template - so try do following thing:

  1. when seeing a pop-up - uncheck 'Immer diese App verwenden" - go to "More Apps" link on this window, scroll downlo until you see option "choose program from this computer" and then browse to: C:\Program Files (x86)\NPrinting\Designer and  choose "NPrintingDesigner.exe"

I am not sure whether this will work for you - but it is worth trying.

regards

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Not applicable
Author

Lech Miszkiewicz <span class="icon-status-icon icon-partner" title="Partner"></span> schrieb:

The pop-up window usually is coming up when system does not know what is the default program to open file.

I am thinking - maybe we could help your system to allocate right program to open nprinting template - so try do following thing:

  1. when seeing a pop-up - uncheck 'Immer diese App verwenden" - go to "More Apps" link on this window, scroll downlo until you see option "choose program from this computer" and then browse to: C:\Program Files (x86)\NPrinting\Designer and  choose "NPrintingDesigner.exe"

I am not sure whether this will work for you - but it is worth trying.

regards

Lech

That's unfurtunately what I've already tried. If i uncheck the only option is still to choose an app out of the window store.

Is this edit template the only possibility to develop a new report?

mkelemen
Creator III
Creator III

Hi Christian,

this seems like the Designer was not installed correctly - did not create the default program association.
Try reinstalling it and make sure you have full admin rights.
BR,

  Matus

Not applicable
Author

Matus Kelemen schrieb:

Hi Christian,

this seems like the Designer was not installed correctly - did not create the default program association.
Try reinstalling it and make sure you have full admin rights.
BR,

  Matus

That's it. Problem solved!

Thank you very much!