Qlik Community

Ask a Question

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

cancel
Showing results for 
Search instead for 
Did you mean: 
jepeerik
Contributor III
Contributor III

NPrinting error 'CEF rendering exception' while generating report in preview

Hi all,

I've upgraded Qlik Sense en NPrinting from sept 2019 to feb 2020 (Patch 1 and later Patch 2). Since then I've got an error while generating a Powerpoint report (request failed) and in Designer I've got a more detailed error popping-up,

a CEF rendering exception 'CEF_ON_JS_ERROR_MESSAGE_RECEIVED'.

Attached the screenshot of the error and the corresponding part of the log.

The report is containing images. The image the error is pointing at its the firs image in the report ('bWBjaa'). If I remove this image from the report, the error points to the next first image in the report.

I also restored a backup of the NPrinting server, so I could test this with NPrinting sep 2019, but then also this error appears.

All communication between the servers is setup with the correct certificates, everything is done in https.

Does anybody has a clue where this error is coming from?
It would be very helpfull, because now I can't generate my report to Powerpoint.
Another report to Excel is still working luckely.

Thanks in advance.
Greetings Jörgen

Sharing knowledge increases your knowledge
Labels (2)
1 Solution

Accepted Solutions
robert_mika
Master III
Master III

I have had a similar problem when I created an object in Published stream.

The NP refused to print no matter what I have tried.

I end up with creating the object again in my workstream.

View solution in original post

7 Replies
robert_mika
Master III
Master III

I have had a similar problem when I created an object in Published stream.

The NP refused to print no matter what I have tried.

I end up with creating the object again in my workstream.

View solution in original post

jepeerik
Contributor III
Contributor III
Author

Hi Robert,

Thanks for your response. And finally this was also the solution for me.
In the QS app I've rebuild all the objects which were causing this error. Even copy-paste of the object was not sufficient. Completely rebuild and replace the objects, even with exact the same settings and measures, was the solution. Very strange.

Thanks for your help.

Greetings,
Jörgen

Sharing knowledge increases your knowledge
wttaryde
Contributor III
Contributor III

If anyone has a different solution, I'd like to hear it. I'm having the same issue. I have 778 pages throughout 18 reports that would have to be rebuilt.  Like you, the first sheet in each report causes the error, remove that one and it's the next first sheet, so it's not really an object issue.

robert_mika
Master III
Master III

Have you made any changes to the app recently?

When did this start to happen?

Do you have section access set up?

Did you create any new master dimension or measure?

I'm trying to recall everything I have had b/f the problem occurs.

 

wttaryde
Contributor III
Contributor III

I have determined that this problem is not related to my App/Report.  I just tried to run a report that had been able to run successfully every day (on schedule) without a single error.  That report now does not run and generates the same error message.  So I'm getting IT Support to restart the NPrinting engine and if that doesn't work to update to the latest release.  Assuming I am then able to run the old report, I'll try again with the new ones that I just built. 

I'll try to remember to post an update later.

Lauri
Specialist
Specialist

hi @wttaryde - did you have any luck? I'm having the same issue with one image.

wttaryde
Contributor III
Contributor III

This was definitely an IT issue.  Rebooting Nprinting helped and we haven't had issues since.