Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor III
Contributor III

NPrinting ignores cell formatting

Hi guys,

I have this issue that I have tried to resolve myself for a week or two where the values of my straight tables are rendering in reports under the 'General' format instead of what I have chosen. I have posted some screenshots to help explain:

1. The qvw with the correct number format (some other tables will need to be a % or have different decimals). I have tried formatting in the expression itself as a workaround but it did not work. I can't select 'Keep source formatting' for this project.

1.PNG

2.  The structure of the Template. You can see the cell is formatted to number. The table will expand across 5 cells and each is formatted to replicate how it is seen in the qvw. Each row will be a different table.

2.PNG

 

3. The result. It has ignored the formatting of the expression and the template editor and reverted to 'General'.

3.PNG

 

I have browsed before posting this question but I could not see a resolution, there were some considered solved but it was for QlikSense, and one post assumed that this problem would be fixed in a newer version of NPrinting (I started this project in NP 16.7 and continued it in the Feb 2020 version).

 

It might not mean much but I did a direct export from the table in the qvw to an excel file just in case the server settings was overruling it and it was matching the qvw.

7 Replies
Highlighted

Re: NPrinting ignores cell formatting

Hi,

well this is quite interesting one

1. Definitely "uncheck Keep source format" to make sure it is not pushed from Qlik.. Also check if keep source format is not selected on individual columns.

2. it would be good to see how this value is created in Qlik

  • do you use num(some formula,'someformat')
  • or
  • do you use "some formula" and create a format in number formatting section for this column

3. Make sure that there are no level tags used in the column where you are placing this tag into. As a good practice I always suggest to have dedicated few columns only for levels, "deleterows" tags etc.. I usually then hide those columns.

4. If the value comes from table, in the NPrinting -> Table->"That column" --> properties; you should be able to enforce format there as well...

I am not sure how sensitive this data is, but having your report template and sample app would definitely help...

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Highlighted
Contributor III
Contributor III

Re: NPrinting ignores cell formatting

Hi Lech,

2. I have tried both ways. Originally just formatting in Number tab then adding the formatting directly in the expression. Everything works fine until the preview is generated.

3. I don't have any levels.

4. I have tried formatting in the Format field for each column.

format.PNG

Still the same result on both Excel and PDF previews. I'm surprised this isn't being commonly reported, I don't see any reason why it would just ignore every attempt to format.

For reference here is one of my expressions which is used as a variable in the object: 

=sum(aggr(sum(DISTINCT{<PLAYER_ID,PRIMARY_POS_DESC-={'Goalkeeper'},PLAYERTEAMNAME=[HOME_TEAM_NAME]>}MAX_METERS),PLAYER_ID))

 

When I wanted to format it using num() I enclosed the variable 

=num($(vVARIABLE),'#,000')

 

Highlighted

Re: NPrinting ignores cell formatting

Hi @AyCe1082 

At this stage I have no other idea. 

If you can share your report template (export report to zip) and qvw file, then I can try to check it on my end. Just attach it here, or if you prefer to use other chanel of communication jus PM me,

It is not reported as the behaviour you are experiencing is unusual and does not happen often (or rather at all) 

cheers 

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Highlighted
Employee
Employee

Re: NPrinting ignores cell formatting

Hi,

Do you have different international settings on the different computers you are using?

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Highlighted
Contributor III
Contributor III

Re: NPrinting ignores cell formatting

Qlikview and NPrinting and all the resources are on the same remote server. I have directly exported to excel to be sure it isn't a computer setting or Excel setting that was causing the issue.

Highlighted
Employee
Employee

Re: NPrinting ignores cell formatting

Hi,

At this point I suggest you to open a support ticket and include everything we need to reproduce the problem. So include the source QVW (also reduced or with scrambled data) and the Qlik NPrinting template. Please specify also the versions of all used softwares.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

Re: NPrinting ignores cell formatting

Hi @AyCe1082 

 

For the benefit of community here is what i found looking at your template. 

Instead of dragging and dropping on excel sheet column tags from entity panel in nprinitng designer you dragged and dropped whole table tag. If you do that you will not be able to format values in table using excel nor properties. 

See screenhot for reference: You were dragging table "Distance" as whole  instead of bringing in individual columns.

Conclusion:

There is no bug - it is working as designed. Please study https://help.qlik.com for details, for example: https://help.qlik.com/en-US/nprinting/February2020/Content/NPrinting/ExcelReports/Create-Excel-Repor...

1.png

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.