Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
QlikWorld, June 24-25, 2020. Free virtual event for DI and DA gurus. Register Today
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

NPrinting seems to be suck when it try to establish the connection

Hello,

I have an issue with NPrinting version November 2018.
From tonight we aren't able to modify a connection, we cannot open NPrinting Designer, we cannot create filters, basically Icannot do anything in NPrinting where one connection is involved.
It seems to be a cache problem. I don't know...

If I go to Task execution, I can see two tasks of Generetion connecion cache with status "Running" but they seems to not work at all. I tried to abort them but it give me an error:

"Something went wrong while aborting execution of the task 'Cache rebuild task for connection xxxx"

If I try to open Connection TAB everything got stuck and to keep using NPrinting I have to reboot the services...

 

Is anyone knows how to solve this problem?


Thank you.

Mirco Grasso

Tags (1)
1 Solution

Accepted Solutions
Highlighted
Partner
Partner

Re: NPrinting seems to be suck when it try to establish the connection

The problem was related to an automatic windows update, we solved the problem installing the newest version of NPrinting (February 2019 SR1) and enabling TLS 1.0 engine.

We followed the following steps founded in this conversation https://community.qlik.com/t5/Qlik-NPrinting-Discussions/NPrinting-engine-remains-offline/m-p/153491...

  1. Start the registry editor by clicking on Start and Run. Type in "regedit" into the Run field (without quotations).
  2. Highlight Computer at the top of the registry tree.  Backup the registry first by clicking on File and then on Export.  Select a file location to save the registry file.

    Note: You will be editing the registry.  This could have detrimental effects on your computer if done incorrectly, so it is strongly advised to make a backup.

  1. browse to the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols

  2. Right click on the Protocols folder and select New and then Key from the drop-down menu. This will create new folder.  Rename this folder to TLS 1.1 or TLS 1.2 (depending on the protocol you want to enable)

  3. Right click on the TLS 1.1 or TLS 1.2 key and add a new key underneath it.
  4. Rename the new key as:
    • Client
  5. Right click on the Client key and select New and then DWORD (32-bit) Value from the drop-down list.
  6. Rename the DWORD to DisabledByDefault.
  7. Right-click the name DisabledByDefault and select Modify... from the drop-down menu.
  8. Ensure that the Value data field is set to 0 and the Base is Hexadecimal.  Click on OK.
  9. Create another DWORD for the Client key as you did in Step 7.
  10. Rename this second DWORD to Enabled.
  11. Right-click the name Enabled and select Modify... from the drop-down menu.
  12. Ensure that the Value data field is set to 1 and the Base is Hexadecimal. Click on OK.
  13. Reboot the server

 

Mirco

View solution in original post

7 Replies
Highlighted
Employee
Employee

Re: NPrinting seems to be suck when it try to establish the connection

Hi,

If you run a verify connection what do you see?

Did you checked the log files?

If it is a connection to a server (QlikView or Qlik Sense) is the server up and running? Are the ports open?

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Highlighted
Partner
Partner

Re: NPrinting seems to be suck when it try to establish the connection

The connection is to a Qlik View Server. That server is up and running. all the ports are opened, nothing change from yesterday, untill yesterday everything worked fine...
I cannot access to the connections.

Thanks,
Mirco
Highlighted
Employee
Employee

Re: NPrinting seems to be suck when it try to establish the connection

Did you restarted the Qlik NPrinting Windows Services?



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Highlighted
Partner
Partner

Re: NPrinting seems to be suck when it try to establish the connection

yeah, restarted everyting multiple times 🙂
Highlighted
Employee
Employee

Re: NPrinting seems to be suck when it try to establish the connection

Check if there are error messages in the log files.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Highlighted
Support
Support

Re: NPrinting seems to be suck when it try to establish the connection

Please check this article for possible solutions to your issue:

How to resolve NP Engine is Offline in the NP Engine Manager or NPrinting Engine Service Will Not St...

https://support.qlik.com/articles/000034575

One more article that 'could' that explains what may be part of the issue:

https://support.qlik.com/articles/000052578

We are just 'like' you & like to be liked when we provide a helpful answer and or when you press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
Highlighted
Partner
Partner

Re: NPrinting seems to be suck when it try to establish the connection

The problem was related to an automatic windows update, we solved the problem installing the newest version of NPrinting (February 2019 SR1) and enabling TLS 1.0 engine.

We followed the following steps founded in this conversation https://community.qlik.com/t5/Qlik-NPrinting-Discussions/NPrinting-engine-remains-offline/m-p/153491...

  1. Start the registry editor by clicking on Start and Run. Type in "regedit" into the Run field (without quotations).
  2. Highlight Computer at the top of the registry tree.  Backup the registry first by clicking on File and then on Export.  Select a file location to save the registry file.

    Note: You will be editing the registry.  This could have detrimental effects on your computer if done incorrectly, so it is strongly advised to make a backup.

  1. browse to the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols

  2. Right click on the Protocols folder and select New and then Key from the drop-down menu. This will create new folder.  Rename this folder to TLS 1.1 or TLS 1.2 (depending on the protocol you want to enable)

  3. Right click on the TLS 1.1 or TLS 1.2 key and add a new key underneath it.
  4. Rename the new key as:
    • Client
  5. Right click on the Client key and select New and then DWORD (32-bit) Value from the drop-down list.
  6. Rename the DWORD to DisabledByDefault.
  7. Right-click the name DisabledByDefault and select Modify... from the drop-down menu.
  8. Ensure that the Value data field is set to 0 and the Base is Hexadecimal.  Click on OK.
  9. Create another DWORD for the Client key as you did in Step 7.
  10. Rename this second DWORD to Enabled.
  11. Right-click the name Enabled and select Modify... from the drop-down menu.
  12. Ensure that the Value data field is set to 1 and the Base is Hexadecimal. Click on OK.
  13. Reboot the server

 

Mirco

View solution in original post