Qlik Community

Ask a Question

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Join us at the Cloud Data and Analytics Tour! REGISTER TODAY
Showing results for 
Search instead for 
Did you mean: 

NPrinting shows only one row of table, need all

Dear Community,

inside a pixel perfect report i add a report header and a detail band.

After that i added a table object and inside the table header i defined the headers of the table and inside the detail band the columns that have a data binding.


When i preview the result, i see only one (the first) row and NOT all the rows of the table.

What did i wrong?

Please help

13 Replies
Creator II
Creator II


Thanks for reply

But how they are showing in videos of Nprinting?

Creator II
Creator II

Hi Aran,

To add table as level, when i click 'add objects' from level,  in popup table i am not able to view or it does not show any objects from my app. it is only showing variables from qliksense edit loader of my app.

Why is it happening like this?Any help is appreciated.

Creator II
Creator II

Dear All,

The solution is simple:


  1. Right click on the Levels node to add a level

    2. Right click on the Detail area in the middle of the page

    3. Select Insert Detail Report

What you are doing is drag drop the table without inserting the detail report (chek circle in red in the below screen showing empty table)


  4. Now you can drag and drop the table as per the below screen and check the name of the table will appear near Detail Report.



Hi Elie,

the solution you are mentioning is quite similar to the steps of the Qlik help page see:


As you can imagine we tried this weeks ago. Unfortunately this is no solution as we still get an error : "Wrong content node response type" Its really frustrating that Qlik can not solve this bug after months.