Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

godfreydaniels
New Contributor III

Non-repeating objects in Pixel Perfect report

Hi,

I have a Pixel Perfect report with a table that spans multiple pages.  I would like to add a title section to the top of the first page only, and have the table begin below it on the first page--so the table would take up the bottom part of the first page, and the next several entire pages.

I also have disclaimer text that fills a full page, so that it should only appear at the end of the report, not as a footer on each page.

How can I achieve these requirements?

Thanks for your help.

Tags (1)
5 Replies
patriciabb
New Contributor II

Re: Non-repeating objects in Pixel Perfect report

Hi,

If you right-clik in the top of the page, you will find te following menu:

menu.png

If you clik in ReportHeader, everything contained there, should appear only once.

If you add the table to "Detail", it should work as you have requested.

If you want your text independant from the rest of the report, you can also clic on the same menu "Insert Detail Report" and then choose "Unbound". Then you can add your text under "Detail Report 1".

If you want to add a Page Break, then clic here:

tools.png

Hope this helps!

godfreydaniels
New Contributor III

Re: Non-repeating objects in Pixel Perfect report

Thank you, Patricia, now I have my report header, but there is still a problem.  My table has column headers, and the only way I got those to repeat once per page is to put them in the space above where the Report Header goes (that is, in the top margin, not inside any type of band).  Now I have a report header that works correctly, except that my column headers appear above it.

I have tried to put my column headers in a number of other places, but everything I've tried causes them to either repeat once per row, or only once per report.  How can I have my column headers once per page, but not show up above the report header?

Thanks

patriciabb
New Contributor II

Re: Non-repeating objects in Pixel Perfect report

Hi Godfrey,

There is an easy way to do that: right clik on "Detail" where your table is, and then clik Insert Band / Group header.

Notice that it shouldn't be left any space neither between the group header and the table, nor between the table and the next detail or footpage, so it looks like a proper table:

This should work fine table.png

godfreydaniels
New Contributor III

Re: Non-repeating objects in Pixel Perfect report

Thank you, Patricia, but it still shows only on the first page.  I feel there must be a setting required as well.  I have tried every option under 'Group Fields,' but it still does not repeat.

godfreydaniels
New Contributor III

Re: Non-repeating objects in Pixel Perfect report

Don't know how I missed it--there is a 'Repeat Every Page' property.  It is working as intended now.

Community Browser