Qlik Community

Ask a Question

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Join us for a live Q&A! September 21, 10 AM ET - Onboarding Fast in Qlik Sense SaaS! REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
PoojaPrasad
Creator II
Creator II

Npriniting Connection shows Cache Status 'Generating' for several hours

Hello Experts,

I have made some changes on Qlik App and then tried to reload the metadata in Nprintimg connection for the Qlik App. The connection shows cache status as generating for several hours. 
I then deleted the connection and created a new one and it still shows Cache Status Generating as shown below in the screenshot:

CacheStatusIssue.PNG

Any idea what could be the issue?

Labels (2)
1 Solution

Accepted Solutions
Frank_S
Support
Support

Please check the article I sent about unsupported QS items to familiarize your self with documented export limitations.

https://support.qlik.com/articles/000038863

You will note that this includes the use of 'alternate states' as a limitation. If you are not aware of these, then you likely haven't added any.

In the meantime, I suggest that since you made these chart changes that you do the following to cover all possibilities:

1. check the QS server and make sure all the QS services are running. If the QS engine is offline, then this would explain why NP connection is not generating.

2. if all running, please restart the QS services and NPrinting services.

3. Refresh and reload the NPrinting Connection to the Sense app with the changes that you added.

4. Additionally and Proactively: Open the report and update any of the charts that have been modified so they are reflected in your report. Right click on table objects used in your report and select 'update' from the right click context menu. (This doesn't fix the connection issue but you will need to do this if you made fundamental changes to your chart.).

Let us know how it goes...

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

6 Replies
PoojaPrasad
Creator II
Creator II
Author

I also checked the below link:

https://community.qlik.com/t5/Qlik-NPrinting-Discussions/Qlik-Nprinting-connection-to-Qlik-Sense-Cac...

Does that mean starting the server is the solution?

 

Lech_Miszkiewicz

You are refering to very old discussion related to very old NPrinting version. 

I would start investigation by checking if all services are running, checking if engine is online and checking logs in debug mode.

The fact that it sits in "Generating" mode for such long time only means that posibly something is wrong, but cannot tell what is wrong.

Also - what would verification process show when you click on it before running metada reload

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Frank_S
Support
Support

@PoojaPrasad 

"Some changes" is not enough information.

If you added an extension that is not supported or a chart visualization that is not supported, this could cause the issue.

If you added an alternate state property, this could cause the issue.

What exactly did you change? That would help us help you better.

You can also check this as well to determine in a change you made could be impacting your results in any way: https://support.qlik.com/articles/000038863

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
PoojaPrasad
Creator II
Creator II
Author

Hello @Frank_S 

Changes:

1. I have arranged the records with ascending order of last name (which is one of the column) in csv file and reloaded the data.

2. Added Emp ID (existing column) in the filter pane on the app.

3. On Nprinting Report, I changed all subtitles from blue to black font and saved.

These changes seemed trivial to me so did not explicitly mention.

Also, 

"If you added an extension that is not supported or a chart visualization that is not supported, this could cause the issue."-I already have been using 'Simple Table w/t link' extension on my app to display images hosted online which has been working okay. (It misses 5% images sometimes on report) But the reports were generated

"If you added an alternate state property, this could cause the issue."- No idea on this. Can you pls let me know more about this?

Frank_S
Support
Support

Please check the article I sent about unsupported QS items to familiarize your self with documented export limitations.

https://support.qlik.com/articles/000038863

You will note that this includes the use of 'alternate states' as a limitation. If you are not aware of these, then you likely haven't added any.

In the meantime, I suggest that since you made these chart changes that you do the following to cover all possibilities:

1. check the QS server and make sure all the QS services are running. If the QS engine is offline, then this would explain why NP connection is not generating.

2. if all running, please restart the QS services and NPrinting services.

3. Refresh and reload the NPrinting Connection to the Sense app with the changes that you added.

4. Additionally and Proactively: Open the report and update any of the charts that have been modified so they are reflected in your report. Right click on table objects used in your report and select 'update' from the right click context menu. (This doesn't fix the connection issue but you will need to do this if you made fundamental changes to your chart.).

Let us know how it goes...

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

PoojaPrasad
Creator II
Creator II
Author

hello @Frank_S 

Thank you for the lists of check. We restarted QS services and NPrinting services. I once again created a new connection to the Qlik app and the cache got generated quickly.

Thank you for your help. 🙂