Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Join us for live office hours! Q&A with Qlik on Dec 14 at 10am EST: Refining Reports and Visualizations
cancel
Showing results for 
Search instead for 
Did you mean: 
mubinoddin
Contributor II
Contributor II

Nprinting Embed HTML report issue in IPAD

Hi,

 

We embed some pictures in mails using Nprinting

...

<img src="%%CH1831%%" alt="CH1831">

...

 

When we open this Emails on Iphone or Ipad , sometimes the picture of another email (opened previously) is displayed.

No problem on Outlook  or Desktop or any other system.

 

Did someone  met this issue before ?

Even tried generating report with new name every time.

 

Kindly help

thanx.

Labels (1)
4 Replies
Lech_Miszkiewicz

Hi, This is purely iPad mail client issue. As you saying everything is fine on other clients like outlook, so report produced in NPrinitng comes out fine. 

Now down to issue,

I believe it is due to caching of emails in iOS . I am just going through options on my iPhone and there is an option to turn on "Load Remote Images", I would definitely have this one on. However i think this is a cache issue - just like this one:

https://discussions.apple.com/thread/7456614

cheers

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
mubinoddin
Contributor II
Contributor II
Author

Can u suggest some way around using some HTML or Javascript coding
Lech_Miszkiewicz

If this would be only possible... 

Pure HTML is not able to change this. Using java script will not work neither as java script is not supported in mail clients for security reasons. 

I mentioned this on other thread on community - this is not NPrinting related issue. All what you can do is ask on apple community how to remove cache from iOS mail client!

cheers

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Lech_Miszkiewicz

I have looked at it little bit more. The problem seems to be ignored by apple team. See below threads:

https://css-tricks.com/forums/topic/iphone-mail-displaying-wrong-images/

https://discussions.apple.com/thread/5146502

https://discussions.apple.com/thread/7456614

 

In the first thread the suggestion was to change email title, content etc... maybe you could add timestamp to your email subject and content in NPrinting to try force iOS mail client to use new image?

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.