Qlik Community

Ask a Question

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Support Cases coming to Qlik Community Oct. 4! Start chats, open cases, explore resources: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
mybayrak
Contributor
Contributor

Nprinting Excel Export Not Working

We have 2 reports that we use Nprinting to export to excel. 2 reports were working properly but suddenly one of the reports started not working. We can not export to excel. There is no error message given. It keeps pending on the screen like it is trying to generate the excel file but it does not end. Where can we check to understand what the problem is?

Labels (2)
2 Replies
Lech_Miszkiewicz

Hi...

We dont have enough information on what you are trying to do. 

I suggest you prepare screenshots with step by step instructions on what you are doing so we could replicate your issue and give you some ideas.

What do you mean when you say "we cannot export to excel".

Do you mean:

  • Preview of NPrinitng Designer template does not create excel
  • or standard Qlik Sense functionality (Export Data) does not work for you
  • or OnDemand report using NPrinitng template and Qlik sense on demand functionality does not produce report
  • or something else... what?

With NPrinting you may want to check the logs on the server - if there is not enough information you may want to change their level to DEBUG. Info how to do this is on Https://help.qlik.com 

Once you have more info what you are actually doing we may be able to help you more.

 

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Frank_S
Support
Support

@mybayrak 

While the information you shared is limited, you may also try:

  • reload the NP connection to the Qlik Sense app. ( some source table objects may have changed)
  • right click on each separate 'table' object under the 'connection' field in the template editor and select 'update' from the context menu.
  • Try to preview your report again.

Make sure you are not using any unsupported QS items:

If you are still having the problem please provide more information including steps to reproduce the issue and images of errors as well as attaching logs.

Kind regards...

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!