Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

sujeet_shirude
Contributor

Nprinting: Not sending email reports to entire group

Hi All,

We have an Nprinting 17.3 report pulling data from Qlik Sense(3.1).  We have a task setup for a group of 50 users but some of the users are not receiving the Nprinting email reports. They received in the beginning but have stopped since the last two weeks. We haven't made any changes to the environment. I checked the user level filter and it is fine. I asked the user to check their Junkmail but its not there. When i check the task Execution log, it is successful for the Group.

  1. What could be the issue?
  2. What are some of other settings/things I need to check?
  3. Is there a User level delivery report(Delivered/Failed) as at the Group/Task level it shows successful?

Any insights on the same are appreciated. Thank you!

Regards,

Sujeet Shirude

Tags (1)
13 Replies
ogster1974
Honored Contributor II

Re: Nprinting: Not sending email reports to entire group

Try adding your email as bcc to a run so you can confirm the 50 emails are being generated by the system. Then at least you know the issue is downstream. 

if they dont generate then confirm the users are definitely part of the group sometimes user imports can overwrite their group access if they appear multiple times.

Set them up individually and check they go out as individuals you might get a more detailed log record.

sujeet_shirude
Contributor

Re: Nprinting: Not sending email reports to entire group

Thanks, Andy! I will try your suggestions.

ogster1974
Honored Contributor II

Re: Nprinting: Not sending email reports to entire group

Let us know how you get on.

Lech_Miszkiewicz
Honored Contributor III

Re: Nprinting: Not sending email reports to entire group

Hi

In order to be a NPrinting report recipient user needs to have a role in NPrinting. Make sure all people from 50 are at least "Users" or "NewsStand User" or have any other role which allows them to receive reports.

Also do what Andy suggested regarding groups.

On top of that  double check whether those users have filters created for them (user filters) which could interfere with your current report.. If they have, make sure those filters are created in seperate NPrinting app on separate connection.

let us know how it goes

regards

Lech

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
sujeet_shirude
Contributor

Re: Nprinting: Not sending email reports to entire group

Thanks, Lech! Yeah, I will keep you posted.

maxxieshi
New Contributor II

Re: Nprinting: Not sending email reports to entire group

Dear,

Have you resolved this issue,

I have also met this issue recently,

we have 500+ users, but there were 90+ users that could not receive E-mail but others were OK,

All users have the same setup ,Excel file were generated correctly and could sent to local folder successfully,

If you resolved it, could you pls have a share, thanks.

sujeet_shirude
Contributor

Re: Nprinting: Not sending email reports to entire group

Hello!

No, I wasn't able to track down the exact cause but users started receiving the report.

I have noticed that if the user does not exist in Qlik Sense app for that day, the report might fail for the user. So check if the users exist in the Qlik Sense app.

As Andy & Lech suggested above check the user groups, roles and user level filters are setup correctly.

I would suggest to upgrade to Nprinting June 2017 version as it has task executions tabs which helps in monitoring. Also, Split the users into multiple groups so you can track down which tasks(groups) fail.

maxxieshi
New Contributor II

Re: Nprinting: Not sending email reports to entire group

Thanks a lot.

Employee
Employee

Re: Nprinting: Not sending email reports to entire group

I agree with all other suggestions and I would to add that you could check the SMTP server logs, maybe there could be some error messages related to the email sending process.

Check also the Qlik NPrinting logs in order to find other errors.

Best Regards,

Ruggero

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Community Browser