Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Coming Aug. 9: New Simplified Authoring for Qlik Sense SaaS – For Details, CLICK HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
Carly_
Contributor III
Contributor III

Nprinting REST API broke after June 2020 update

Goodmorning,

I have a failing script trying to call the Nprinting REST API after updating both Qlik and NPrinting to the June version. I also had this after the February update. The cookie is the problem in both cases. However, then I could easily change it by adjusting the TextBetween formula and now I cannot resolve the issue. Does anybody have an idea on how to change the cookie value so that the connection can be made again? 

I cannot find anything in the release notes this time. 

Labels (2)
39 Replies
Carly_
Contributor III
Contributor III
Author

That seems like a great solution, where can I find that previous version of the REST connector? In the downloads page from Qlik I can only find the QlikView versions. 

eike_soecker
Partner - Contributor III
Partner - Contributor III

I think Qlik would have to provide a separate link for this. I still had an April version on hand (see attachment, of course without warranty and without guarantee). Make a backup of the old folder first. Stop the engine, swap versions of the folders and restart the engine. As I said, this is all just a workaround.

Carly_
Contributor III
Contributor III
Author

Thank you Eike, for now this was the solution. It works again, it is not perfect, but i'm glad it is resolved for now. 

Ruggero_Piccoli
Support
Support

Hi,

Please try to replace the code:

Let vCookie = TextBetween('$(vCookieRaw)','SameSite=None,','Path=/',2);

With:

Let vCookie = TextBetween(vCookieRaw,'SameSite=None,',' Path=/',SubStringCount(vCookieRaw,'SameSite=None')-1);

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Fred
Partner - Creator
Partner - Creator

@Ruggero_Piccoli 
Unfortunatley your code does not solve the issue (at least for QS June 2020 SR3 & NP June 2020 SR1).
There is some weird stuff going on with the cookies format and rest connector.

Replacing the rest connector with the april version still does the trick.

Are you guys already aware of this and/or investigating this? Otherwise I'll log a support ticket.

Thanks.
 

Carly_
Contributor III
Contributor III
Author

@Fred It would be great if you could file a support ticket. The proposed resolution does not work and I still have the april version running, which does work well indeed. 

Ruggero_Piccoli
Support
Support

Hi,

We are already aware and working on this issue. If you want you can rise a support ticket, but it is not mandatory for this topic.

Thanks.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Qlik_Greg
Contributor
Contributor

Hi Ruggero.

Can you explain the issue succinctly?  What works, what doesn't work here... and status on a resolution.  We have upgraded to NPrinting June 2020 and planned to upgrade to QS June 2020 next week, but ran into, what I believe are, related issues to what is being discussed here in our QS Sandbox environment.

micheledenardi
Specialist II
Specialist II

Hi Ruggero,

are there news on this topic?

i would avoid to replace RestConnector 2.34 (june 2020 patch 3) with previous versions...

The "set-cookie" returned has this structure:

NPWEBCONSOLE_XSRF-TOKEN=VR+Yk8FFNjcMg7gRSCQomIy2TkeAP380diD5JWVJZqg=; Path=/,NPWEBCONSOLE_SESSION=46f3820aa1ac24541d21efed2016cf10f9703126-%00NPWEBCONSOLE_XSRF-TOKEN%3AVR%2BYk8FFNjcMg7gRSCQomIy2TkeAP380diD5JWVJZqg%3D%00%00_TS%3Asession%00%00userid%3Abb9a2592bebd462abe70ed269837134a%00%00userlogin%3A2020-08-07T11%3A52%3A49.2135421Z%00; Path=/; HttpOnly

 So no traces about "SameSite=None".

Michele De Nardi
If a post helps to resolve your issue, please accept it as a Solution.
ingoginqo
Partner - Contributor III
Partner - Contributor III

Hi Ruggero,

we have multiple customers/environments affected by this issue in the June 2020 REST Connector.

 

Can you provide a status update here, or do you want us to open more tickets on this issue?

 

Thank you,

Ingo.